Сохранение нумерации в таблице при удалении строк в EXCEL

Если номера строк в таблице введены вручную, то при удалении строк таблицы нумерация собьется. Ищем решения, чтобы этого избежать.


Самый простой вариант сохранить нумерацию в таблице при удалении строк – это использовать формулу на основе функции СТРОКА() . Записав формулу =СТРОКА()-СТРОКА($A$5) , где СТРОКА($A$5) – строка заголовка таблицы, получим искомое решение (см. файл примера )

Другой вариант – формула =ЕСЛИ(СЖПРОБЕЛЫ(E6)<>"";СЧЁТЗ($E$5:E5)&".";"")

В ячейке E 5 содержится заголовок одного из столбца таблицы. Номер строки выводится с точкой на конце. Преимущество этого варианта состоит в том, что номера строк выводятся только для строк, в которых заполнены ячейки в столбце Е . Если значение в ячейке столбца Е отсутствует, то номер соответствующей строки не отображается.

СОВЕТ: Другим вариантом поддержания правильной нумерации строк является использование таблиц в формате Excel 2007 . Об этом читайте в статье Автоматическая нумерация при добавлении строк .


Комментарии
Только для авторизованных пользователей

(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved