Сохранение нумерации в таблице при удалении строк в MS EXCEL

Если номера строк в таблице введены вручную, то при удалении строк таблицы нумерация собьется. Ищем решения, чтобы этого избежать.

Самый простой вариант сохранить нумерацию в таблице при удалении строк – это использовать формулу на основе функции СТРОКА(). Записав формулу =СТРОКА()-СТРОКА($A$5), где СТРОКА($A$5) – строка заголовка таблицы, получим искомое решение (см. файл примера)

Другой вариант – формула
=ЕСЛИ(СЖПРОБЕЛЫ(E6)<>"";СЧЁТЗ($E$5:E5)&".";"")

В ячейке E5 содержится заголовок одного из столбца таблицы. Номер строки выводится с точкой на конце. Преимущество этого варианта состоит в том, что номера строк выводятся только для строк, в которых заполнены ячейки в столбце Е. Если значение в ячейке столбца Е отсутствует, то номер соответствующей строки не отображается.

СОВЕТ:
Другим вариантом поддержания правильной нумерации строк является использование таблиц в формате Excel 2007. Об этом читайте в статье Автоматическая нумерация при добавлении строк.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4.5 (4 оценок)