Последний день в MS EXCEL на n-й неделе (на 5-й неделе года)

Если известен номер недели, то можно найти, дату последнего дня этой недели.

Существует 2 способа определения номера недели: в соответствии со стандартом ИСО и с помощью функции НОМНЕДЕЛИ(). Подробности можно прочитать в статье Номер недели в году.

Функция НОМНЕДЕЛИ()

Функция НОМНЕДЕЛИ() считает, что первая неделя года начинается с 1-го января. В ней может быть от 1 до 7 дней. Пусть в ячейке A5 содержится год, а в B5 – номер недели в этом году. Нижеследующая формула определяет дату соответствующую последнему дню недели.
=ДАТА(A5;1;1)+B5*7-ДЕНЬНЕД(ДАТА(A5;1;1);2)

Если, например, в ячейке А6 введено число 2012 (год), а в B6 - число 2 (номер недели), то формула вернет дату 08.01.2012 - последний день второй недели 2012 года.

Проблемы могут возникнуть, если пользователь введет номер последней недели в году, т.к. будет выведена дата принадлежащая следующему году. Этого результата можно избежать с помощью формулы:
=ЕСЛИ(B6<НОМНЕДЕЛИ(ДАТА(A6;12;31);2);ДАТА(A6;1;1)+B6*7-ДЕНЬНЕД(ДАТА(A6;1;1);2);ДАТА(A6;12;31))

Теперь, если пользователь в ячейку B1 ввел значение равное или большее номера последней недели в году, то будет выведена последняя дата в этом году, т.е. 31 декабря.

Стандарт ИСО

Если номер недели задан по стандарту ИСО, то нижеследующая формула определит дату соответствующую последнему дню недели.
=ДАТА(A5;1;B5*7+4)-ДЕНЬНЕД(ДАТА(A5;1;3))

При задании номера недели по стандарту ИСО необходимо помнить, что последняя неделя года (52 или 53) может заканчиваться уже в новом году, и наоборот, первая неделя нового может начинаться в предыдущем году.

Если требуется определить на какой день попадает воскресенье (т.е. последний день текущей недели), то читайте статью Понедельник или воскресенье текущей недели.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (3 оценок)