Отбор значений из заданной строки вне зависимости от фильтра в EXCEL

Файл примера

Вывести значение из заданной строки таблицы не представляет труда - используйте функцию ИНДЕКС() . Но, если в таблице действет Автофильтр , то задача усложняется.


Пусть дана таблица с двумя столбцами:

Требуется вывести значение из правого столбца таблицы, которое расположено в 10-й строке. Это можно сделать с помощью функции ИНДЕКС() , см. статью Функция ИНДЕКС() в MS EXCEL .

Если к таблице применен Автофильтр , то определить 10-ю строку можно с помощью идей из статьи Автоматическая перенумерация строк при применении фильтра в MS EXCEL (см. файл примера ). Сначала мы пронумерум строки (левый столбец) в зависимости от фильтра.

Затем для вывода значения используйте формулу =СУММЕСЛИ(A11:A29;A7;B11)

Для удобства требуемая строка выделена с помощью Условного форматирования .

Файл примера

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved