Отбор уникальных ТЕКСТовых значений с учетом РЕгиСТра в EXCEL

Имея список с повторяющимися текстовыми значениями, создадим список, состоящий только из уникальных значений. Отбор уникальных значений будем производить с учетом РЕгиСТра.


Предположим, что имеются текстовые значения, состоящие из букв в различных регистрах, например: ЯБЛОКИ, яблоки, Яблоки, яблокИ, ябЛОки и т.д.

Список уникальных значений можно сформировать с применением формул массива , используя два столбца. В файле примера список уникальных значений сформирован в столбце B с использованием служебного столбца С .

В столбце С содержится формула: =ЕСЛИ(ПОИСКПОЗ(ИСТИНА;СОВПАД(A5;$A$5:$A$19);0)=(СТРОКА()-СТРОКА($A$4)); ПОИСКПОЗ(ИСТИНА;СОВПАД(A5;$A$5:$A$19);0);"")

Результат – позиции первых вхождений значений с учетом регистра.

В столбце B содержится итоговая формула: =ЕСЛИОШИБКА(ИНДЕКС($A$5:$A$19;НАИМЕНЬШИЙ($C$5:$C$19;СТРОКА(A1)));"")

Результат – список без повторов.


© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved