Нумерация строк в EXCEL

Используем различные подходы для нумерации строк.


Используем формулы

Пусть в ячейке A2 введено значение 1 (номер первой строки). В следующую строку таблицы, в ячейку А3 , вводим формулу =А2+1 и копируем ее в ячейки ниже.

Так как в формуле мы сослались на ячейку выше с помощью относительной ссылки , то EXCEL при копировании вниз модифицирует вышеуказанную формулу в =А3+1 , затем в =А4+1 и т.д., тем самым формируя числовую последовательность 2, 3, 4, ...

Другим вариантом является использование формулы =СТРОКА()-СТРОКА($A$1) . В ячейке А1 должен находиться заголовок столбца.

Для чрезстрочной нумерации используйте формулу (см. файл примера ) =ЕСЛИ(ЕЧЁТН(СТРОКА());"";A7+1)

Используем клавишу CTRL



Пусть, как и в предыдущем примере, в ячейку A2 введено значение 1 . Выделим ячейку A2 . Удерживая клавишу CTRL , скопируем Маркером заполнения (при этом над курсором появится маленький плюсик), значение из A 2 в ячейки ниже. Получим последовательность чисел 1, 2, 3, 4 …

ВНИМАНИЕ! Если на листе часть строк скрыта с помощью фильтра , то этот подход и остальные, приведенные ниже, работать не будут. Чтобы разрешить нумерацию строк с использованием клавиши CTRL , выделите любую ячейку с заголовком фильтра и дважды нажмите CTRL + SHIFT + L (сбросьте фильтр).

Используем начало последовательности

Если начало последовательности уже задано (т.е. задан первый элемент и шаг последовательности), то пронумеровать строки можно следующим образом :

  • пусть в ячейке А2 введено значение 1 , а в ячейке А3 значение 2 ;
  • выделяем ячейки A 2 и A 3 ;
  • беремся за правый нижний угол и Маркером заполнения протягиваем вниз.

Получаем результат как в предыдущем случае. Если в ячейке А3 введено значение 3 , т.е. задан шаг последовательности равный 2, то мы получим последовательность нечетных чисел.

Использование инструмента Прогрессия

Воспользуемся стандартным средством EXCEL для создания прогрессий, в то числе и арифметических.

  • вводим в ячейку А2 значение 1 ;
  • выделяем диапазон A 2:А6 , в котором будут содержаться номера строк;
  • вызываем инструмент Прогрессия ( Главная/ Редактирование/ Заполнить/ Прогрессия... ), в появившемся окне нажимаем ОК.

СОВЕТ: О специальных случаях нумерации строк можно почитать в статьях Автоматическая перенумерация строк при применении фильтра , Автоматическая нумерация при добавлении строк , Сохранение нумерации при удалении строк , Нумерация строк и столбцов римскими цифрами и Нумерация столбцов буквами .


Комментарии
Только для авторизованных пользователей

Аноним, 24 октября 2018 г.
как нумеровать через строку?
Михаил, 25 октября 2018 г.
Хороший вопрос, добавил формулу в раздел статьи о нумерации строк формулами, также сделал файл примера.
Аноним, 15 марта 2019 г.
число- пустая ячейка-число- пустая ячейка. Выделяем эти 4 ячейки и тянем за маркер вниз.
(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved