Контроль ввода ОШИБочных значений в MS EXCEL. Часть 3 - с применением формул

Создадим формулу для подачи сигнала пользователю при вводе ошибочного значения. Под «ошибочным значением» здесь будем понимать значение, не принадлежащее заданному диапазону.

Предположим, что на листе EXCEL производятся некие вычисления. Пусть в качестве исходных данных пользователь должен ввести в ячейку А2 числовой параметр из определенного интервала (например, от 1 до 5). При вводе числа, не принадлежащего этому интервалу, с помощью формулы подадим сигнал пользователю. В случае ошибки, формула выдаст соответствующее предупреждение. Формулу создадим в ячейке B2.

В ячейке B2 запишем формулу:
=ЕСЛИ(ИЛИ(A2<1;A2>5);"Введите число от 1 до 5";"ОК")

Если в ячейке А2 будет введено значение из интервала от 1 до 5, то ячейка B2 будет содержать значение «ОК», в противном случае в ячейке появится предупреждающий текст «Введите число от 1 до 5» (см. Файл примера)

Также контроль ввода неверных данных можно организовать с помощью Условного форматирования (см. статью Контроль ввода ошибочных значений с применением Условного форматирования) или Проверки данных (см. статью Контроль ввода ошибочных значений с применением Проверки данных). В отличие от Условного форматирования и формул, которые только информируют о допущенных ошибках ввода, инструмент Проверка данных позволяет запретить сам ввод ошибочных значений.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4.5 (2 оценок)