Какие элементы у 2-х списков в EXCEL общие?

Пусть дано 2 списка значений. Определим, какие элементы первого списка содержатся во втором.


Пусть Список1 находится в диапазоне A2:A17 , Список2 - в диапазоне B 2: B 9 .

Определим какие элементы из первого списка присутствуют во втором (см. Файл примера ).

Решение основано на формуле =СУММПРОИЗВ((A2=$B$2:$B$17)+0) , которая рассчитывается для каждого элемента первого списка.

Эту же формулу можно использовать и в Условном форматировании .

СОВЕТ: Более подробное сравнение 2-х списков описано в статье Сравнение 2-х списков .

Комментарии
Только для авторизованных пользователей

Аноним, 26 сентября 2015 г.
а г де файл примера?
Аноним, 4 апреля 2016 г.
Основатели и команда Excel2.ru, вы красавчики!
Михаил, 10 июля 2016 г.
Внизу статьи, сразу после рекламы. Голубая кнопка.
(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved