Функция СЧЕТ() - Подсчет ЧИСЕЛ (в диапазонах с ТЕКСТом и ЧИСЛАми) в EXCEL

Подсчитаем количество ячеек содержащих числа с помощью функции СЧЁТ ( ) , английская версия COUNT() . Предполагаем, что диапазон содержит числа и числовые значения в текстовом формате.


При подсчете числовых значений в списках, содержащих числа, текст и пустые ячейки, проблем не возникает – используйте функцию СЧЁТ() . Эта функция игнорирует и текст (в том числе и числовые значения в текстовом формате) и пустые ячейки .

Другим вариантом подсчета является использование формулы на основе функции СУММПРОИЗВ() : =СУММПРОИЗВ(--(A1:A10<""))

Удивительно, но получается, что все числовые значения «меньше» значения Пустой текст ("") и любого текстового значения.

Если число находится в текстовом формате, то оно не будет подсчитано. Если при подсчете требуется также учесть и числа находящиеся в текстовом формате , то нужно использовать формулу: =СУММПРОИЗВ((ДЛСТР(A1:A10)>0)*ЕЧИСЛО(A1:A10+0))


Комментарии
Только для авторизованных пользователей

Аноним, 27 июня 2019 г.
КАКИЕ БУДУТ ФУНКЦИИ В АНГЛИЙСКОМ ВАРИАНТЕ?
Михаил, 29 июня 2019 г.
в преамбуле к статье написано COUNT()
Михаил, 29 июня 2019 г.
откройте файл примера в англ EXCEL и все функции будут переведены. файл примера - синяя кнопка - внизу статьи
(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved