Функция ДЕНЬНЕД() в MS EXCEL

Функция ДЕНЬНЕД(), английский вариант WEEKDAY(), возвращает день недели, соответствующий дате. По умолчанию день недели определяется как целое число в интервале от 1 (воскресенье) до 7 (суббота).

Синтаксис функции

ДЕНЬНЕД(дата;[тип])

Дата  — дата, день недели которой требуется найти. Даты должны вводиться в поддерживаемом EXCEL формате (28/02/2011, 28 февраль 2011 и т.д.) или в числовом формате или как результат вычисления других формул или с использованием функции ДАТА(). Например, для указания даты 28.02.2011 следует воспользоваться выражением ДАТА(2011;2;28).

Тип  — число 1, 2 или 3. Если аргумент тип равен 1 или опущен, то Воскресенье считается первым днем недели, Понедельник - вторым и т.д. Если аргумент тип равен 2, то Понедельник считается первым днем недели, Вторник - вторым и т.д. (так принято в РФ). Если аргумент тип равен 3, то Понедельнику соответствует 0, Вторнику - 1 и т.д.

Примеры

Если в ячейке А1 находится дата 28.02.2011 , то формула =ДЕНЬНЕД(A1;2) вернет день недели этой даты, т.е. число 1, что соответствует понедельнику.

=ДЕНЬНЕД("01.03.2011";2) вернет 2, что соответствует вторнику.

Альтернативные решения

День недели можно также определить с помощью Пользовательского формата. Пользовательский формат можно ввести через диалоговое окно Формат ячеек, вкладка Число, (все форматы). Для отображения вместо даты дня недели, на который она приходится, в поле Тип, предварительно все из него удалив, нужно ввести ДДД (краткий формат дня недели, например, Сб) или ДДДД (будет отражено суббота). В ячейке все равно будет содержаться дата, а не число от 1 до 7 (или от 0 до 6), как в случае ДЕНЬНЕД().

Другим способом, определения дня недели является преобразование даты в текстовую форму с определенным форматом:
=ТЕКСТ(01/01/10;"дддд")
Формула вернет текстовое значение "суббота".

Для того, чтобы вывести день недели на английском языке (Sun, Mon, ...) используйте формулу =ТЕКСТ(A6;"[$-809]ДДД")

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (5 оценок)