Функция ЧАСТОТА() - Подсчет ЧИСЛОвых значений в EXCEL

Файл примера

Функция ЧАСТОТА( ) , английская версия FREQUENCY() , вычисляет частоту попадания значений в заданные пользователем интервалы и возвращает соответствующий массив чисел.


Функцией ЧАСТОТА() можно воспользоваться, например, для подсчета количества результатов тестирования, попадающих в определенные интервалы (См. Файл примера )

Синтаксис функции

ЧАСТОТА ( массив_данных ; массив_интервалов )

Массив_данных — массив или ссылка на множество ЧИСЛОвых данных, для которых вычисляются частоты.

Массив_интервалов — массив или ссылка на множество интервалов, в которые группируются значения аргумента «массив_данных».

Функция ЧАСТОТА() вводится как формула массива после выделения диапазона смежных ячеек, в которые требуется вернуть полученный массив распределения (частот). Т.е. после ввода формулы необходимо вместо нажатия клавиши ENTER нажать сочетание клавиш CTRL+SHIFT+ENTER .

Количество элементов в возвращаемом массиве на единицу больше числа элементов в массиве « массив_интервалов ». Дополнительный элемент в возвращаемом массиве содержит количество значений, превышающих верхнюю границу интервала, содержащего наибольшие значения (см. пример ниже).

Пример



Пусть в диапазоне А2:А101 имеется исходный массив чисел от 1 до 100.

Подсчитаем количество чисел, попадающих в интервалы 1-10; 11-20; ...91-100.

Сформируем столбце С массив верхних границ диапазонов (интервалов). Для наглядности в столбце D сформируем текстовые значения соответствующие границам интервалов (1-10; 11-20; ...91-100).

Для ввода формулы выделим диапазон Е2:Е12 , состоящий из 11 ячеек (на 1 больше, чем число верхних границ интервалов). В Строке формул введем =ЧАСТОТА($A$2:$A$101;$C$2:$C$11) . После ввода формулы необходимо нажать сочетание клавиш CTRL+SHIFT+ENTER . Диапазон Е2:Е12 заполнится значениями:

  • в Е2 - будет содержаться количество значений из А2:А101 , которые меньше или равны 10;
  • в Е3 - количество значений из А2:А101 , которые меньше или равны 20, но больше 10;
  • в Е11 - количество значений из А2:А101 , которые меньше или равны 100, но больше 90;
  • в Е12 - количество значений из А2:А101 , которые больше 100 (таких нет, т.к. исходный массив содержит числа от 1 до 100).

Примечание . Функцию ЧАСТОТА() можно заменить формулой = СУММПРОИЗВ(($A$5:$A$104>C5)*($A$5:$A$104<=C6)) (См. Файл примера )

Файл примера

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved