День недели в EXCEL

Определим день недели для заданной даты в ячейке. Существует несколько решений в зависимости от того результата, который мы хотим получить: номер дня недели (1 - Пн, 2- Вт, ...), текстовую форму (Понедельник, Вторник, ...) или просто можно изменить формат ячейки.


День недели можно быстро отобразить с помощью Пользовательского формата . Пользовательский формат можно ввести через диалоговое окно Формат ячеек , вкладка Число , ( все форматы ), нажав CTRL+1 . Для отображения вместо даты дня недели, на который она приходится, в поле Тип, предварительно все из него удалив, нужно ввести ДДД (краткий формат дня недели, например, Сб ) или ДДДД (будет отражено Суббота ).

Другим способом, определения дня недели является преобразование даты в текстовую форму с определенным форматом (см. файл примера ): =ТЕКСТ(01/01/10;"дддд")

Формула вернет текстовое значение " суббота ".

Для определения дня недели через числовую форму (понедельник=1; вторник=2, …) существует функция ДЕНЬНЕД() , английская версия WEEKDAY().

Если дата находится в ячейке А1 , то формула =ДЕНЬНЕД(A1;2) вернет день недели. Номер 1 соответствует понедельнику.

Для того, чтобы вывести день недели на английском языке используйте формулу = ТЕКСТ(A6;"[$-809]ДДД")

Другие статьи на эту тему можно найти в разделе Неделя, День недели .


Комментарии
Только для авторизованных пользователей

Аноним, 12 июля 2016 г.
Добрый день! Подскажите пжл, можно ли по номеру недели внести в ячейку эксель дату понедельника и пятницы этой недели через тире?? Спасибо!
Михаил, 13 июля 2016 г.
Добрый день, вот в этом разделе посмотрите http://excel2.ru/gruppy-statey/nedelya-den-nedeli
Аноним, 14 июля 2016 г.
Спасибо большое!!
Аноним, 14 июля 2016 г.
[id295933596|Михаил], спасибо большое!!! :)
Аноним, 2 ноября 2016 г.
добрый день! Как в экселе установить отклонение на количество недель? То есть - на сколько недель просрочено (выполнение задач привязано не к месяцу или дня, а к конкретной неделе). Нужна функция, которая автоматически будет отнимать "план" от "факта", факт равен текущей недел
Михаил, 2 ноября 2016 г.
=ЕСЛИ(B1>A1;B1-A1;"Выполнено в срок или с опережением") в1 - факт, а1- план (в ячейках указаны номера недель)
Аноним, 2 ноября 2016 г.
[id295933596|Михаил], спасибо, красиво и просто!
Аноним, 22 ноября 2016 г.
Подскажите пожалуйста, как отфильтровать расширенной фильтрацией определенный день недель. Задача такая: 10 человек(ФИО, дата рождения) нужно через фильтр вывести в другую ячейку только тех людей, которые родились в понедельник. Через формулу ЕСЛИ, не выводя отдельный столбец с номером недели к каждой дате рождения пользуясь одной формулой через буксировку ко всем датам рождения.
Михаил, 23 ноября 2016 г.
Создайте доп.столбец с формулой ДЕНЬНЕД(A1;2), где в А1 Дата рождения. Отфильтруйте по значениям, где формула возвращает 1. Я тоже себя лайкнул ))
Аноним, 30 ноября 2016 г.
У меня Excel 2013. Функция ТЕКСТ(дата;"формат") выдает формат, т.е. например, ддд или дддд (а не названия дней недели)
Михаил, 1 декабря 2016 г.
Скорее всего, что-то с региональными настройками. У меня формула =ТЕКСТ(E19;"ddd") выдает ddd, т.е. символ d(day) в русской версии не интерпретируется как надо. А у Вас д (день) воспринимается как просто символ. Попробуйте ввести ddd. Может у Вас англ. windows?
Аноним, 24 января 2017 г.
Помогите пожалуйста! Пишу [$-FC19]ДД ММММ получаю 09 января Пишу ДДДД получаю понедельник А пишу вместе [$-FC19]ДД ММММ, ДДДД получаю 09 января, Monday Почему понедельник стал на английском языке?
Михаил, 24 января 2017 г.
Как вариант =ТЕКСТ(K19;" [$-fc19] ДД ММММ, ")&ТЕКСТ(K19;"дддд"). В Формате ячеек так сделать не удастся
Аноним, 2 июня 2020 г.
А как сделать, чтобы дни недели отображались на другом языке? Например, на иврите.
Михаил, 4 июня 2020 г.
Здравствуйте, вот таблица кодов https://blog.csdn.net/2066/article/details/45555 Ваша формула =ТЕКСТ(A1;"[$-40d]ДДД") для другого языка нужно в формулу =ТЕКСТ(A1;"[$-ХХХХ]ДДД") вместо ХХХХ подставить код языка в шестнадцатиричном формате
(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved