День недели в EXCEL

Определим день недели для заданной даты в ячейке. Существует несколько решений в зависимости от того результата, который мы хотим получить: номер дня недели (1 - Пн, 2- Вт, ...), текстовую форму (Понедельник, Вторник, ...) или просто можно изменить формат ячейки.


День недели можно быстро отобразить с помощью Пользовательского формата . Пользовательский формат можно ввести через диалоговое окно Формат ячеек , вкладка Число , ( все форматы ), нажав CTRL+1 . Для отображения вместо даты дня недели, на который она приходится, в поле Тип, предварительно все из него удалив, нужно ввести ДДД (краткий формат дня недели, например, Сб ) или ДДДД (будет отражено Суббота ).

Другим способом, определения дня недели является преобразование даты в текстовую форму с определенным форматом (см. файл примера ): =ТЕКСТ(01/01/10;"дддд")

Формула вернет текстовое значение " суббота ".

Для определения дня недели через числовую форму (понедельник=1; вторник=2, …) существует функция ДЕНЬНЕД() , английская версия WEEKDAY().

Если дата находится в ячейке А1 , то формула =ДЕНЬНЕД(A1;2) вернет день недели. Номер 1 соответствует понедельнику.

Для того, чтобы вывести день недели на английском языке используйте формулу = ТЕКСТ(A6;"[$-809]ДДД")

Другие статьи на эту тему можно найти в разделе Неделя, День недели .


© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved