Текстовые последовательности в MS EXCEL

Создадим последовательности текстовых значений различных видов: первый, второй, третий, ... товар1, товар2, товар3, ... А, Б, В, ...1-й период, 2-й период, ...1), 2), ... Также создадим последовательности произвольного вида.

Последовательности значений, содержащие текст и числа

Создадим последовательность товар1, товар2, товар3, .... или 1-й период, 2-й период, ...

В ячейку А1 введите значение товар1. Маркером заполнения с копируйте значение в ячейки ниже: в А2 у нас появится Товар2, в А3 Товар3 и т.п.

Примечание. Если нужно чтобы в А2 и А3 также были значения товар1, то при копировании удерживайте нажатой клавишу CTRL.

Другой пример: создадим последовательность текст1, текстA, текст2, текстA

  • в ячейку А2 введите текст1, а в ячейку А3 текстA;
  • выделите ячейки A2 и A3;
  • беремся за правый нижний угол и Маркером заполнения протягиваем вниз.

Получаем результат текст1, текстA, текст2, текстA, ...

Вышеуказанным способом не удастся создать последовательность 1), 2), 3), ...  Для этого нужно использовать формулу =СТРОКА(A2)-СТРОКА($A$1)&")" (см. статью Числовые последовательности). В результате получим вертикально размещенную последовательность. Другой вариант - формула =ТЕКСТ(СТРОКА(A1);"0)")

Чтобы начать нумерованный список с кода 00-01, введите формулу =ТЕКСТ(СТРОКА(A1);"00-00") в первую строку и скопируйте вниз (см. файл примера).

Алфавит

Создадим последовательность символов, сортированных по алфавиту А, Б, В, ... А, В, С ... Для русского алфавита используем формулу =СИМВОЛ(192+СТРОКА(A1)-1), для английского =СИМВОЛ(65+СТРОКА(A1)-1). 192 – код русской буквы А.

Формулы можно разместить в любой ячейке листа. Скопировав ее вниз, получим алфавит, размещенный вертикально. Для создания последовательности, размещенной горизонтально, вместо функции СТРОКА() используйте функцию СТОЛБЕЦ().

Числовые последовательности прописью

Создадим последовательность вида первый, второй, третий, ... В зависимости от требуемой длины последовательности будем использовать разные подходы.

Если требуется создать последовательность из 3-5 элементов, то можно использовать формулу =ВЫБОР(СТРОКА(A1);"первый";"второй";"третий";"четвертый";"пятый")

Если требуется создать последовательность из 10-15 элементов, то можно использовать пользовательский список автозаполнения. Введем в диапазон ячеек D3:D12 значения: первый, второй, третий, ...десятый. Вызовем пункт меню Кнопка Офис/ Параметры Excel/ Основные/ Основные параметры работы с Excel/ Изменить списки. Произведем импорт значений из ячеек.

Теперь введя значение "первый" и, скопировав это значение с помощью Маркера заполнения в соседние ячейки, получим требуемую последовательность.

Если требуется создать последовательность из количества элементов более 15, то имеет смысл воспользоваться подходом изложенным в статье Число прописью.

СОВЕТ: 

О числовых последовательностях вида 1, 2, 3, ... 1, 3, 5, 7, ... I, II, III, IV, ... можно прочитать в статье Числовые последовательности.
О последовательностях значений в формате дат (и времени) вида 01.01.09, 01.02.09, 01.03.09, ..., янв, апр, июл, ..., пн, вт, ср, ... можно прочитать в статье Последовательности дат и времен.
О нумерации строк можно почитать в одноименной статье Нумерация строк.
О массивах значений, содержащих последовательности конечной длины, используемых в формулах массива, читайте в статье Массив значений (или константа массива или массив констант).

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 3.7 (3 оценок)
Яндекс.Метрика