Сколько значений в массиве больше или меньше заданного?

Файл примера

Вычислим в MS EXCEL количество значений в массиве, которые больше (или меньше) заданного числа.


Пусть исходный массив в диапазоне ячеек А12:А62 содержит 51 значение (см. файл примера ).

Найти сколько значений в массиве больше заданного числа можно используя формулу: =СЧЁТЕСЛИ(A12:A62;">"&B6)

В формуле предполагается, что заданное число, с которым производится сравнение (критерий), размещено в ячейке В6 . Чтобы подсчитать какой процент значений больше критерия - имспользуйте формулу =СЧЁТЕСЛИ(A12:A62;">"&B6)/СЧЁТ(A12:A62)

Аналогичным образом можно подсчитать % от общего количества значений, которые:

  • больше или равны критерию: =СЧЁТЕСЛИ(A12:A62;">="&B6)/ СЧЁТ(A12:A62)
  • меньше критерия: =СЧЁТЕСЛИ(A12:A62;"<"&B6)/ СЧЁТ(A12:A62)
  • меньше или равны критерию: =СЧЁТЕСЛИ(A12:A62;"<="&B6)/ СЧЁТ(A12:A62)

Если список значений отсортирован по возрастанию , то для подсчета количества значений, которые больше критерия, можно использовать формулу =РАНГ(ВПР(B6;A12:A62;1);A12:A62)-1

Файл примера

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved