Разделяем пробелами Фамилию, Имя и Отчество

Если фамилия, имя и отчестсво написаны слитно, например, «ПетровИванИванович», то можно создать формулу их разделения, чтобы получить «Петров Иван Иванович» .


Пусть имеется текстовая строка с именем, записанным слитно: ПетровИванИванович. Причем, фамилия, имя и отчество написаны с заглавных букв. Используем это для разделения частей имени пробелами (см. файл примера ).

C помощью функции КОДСИМВ() определим является ли буква заглавной (прописной) , если да, то выведем перед ней пробел.

Сначала создадим вспомогательную таблицу для вывода позиций ПРОПИСНЫХ символов (в столбцах F:ВВ , всего 50 символов).

Формула =ЕСЛИ(ЕСЛИОШИБКА(КОДСИМВ(ПСТР($A5;F$4;1));999)<224;F$4;0) будет возвращать позицию ПРОПИСНЫХ символов, начиная со второго.

В столбцах C:E с помощью формул

=ЛЕВСИМВ(A5;НАИБОЛЬШИЙ($F5:$AI5;2)-1)

=ПСТР(A5;НАИБОЛЬШИЙ($F5:$AI5;2);НАИБОЛЬШИЙ($F5:$AI5;1)-НАИБОЛЬШИЙ($F5:$AI5;2))

=ПРАВСИМВ(A5;ДЛСТР(A5)-НАИБОЛЬШИЙ($F5:$AI5;1)+1)

выведем фамилию, имя и отчество.

И, наконец, в столбце В получим требуемый результат с помощью формулы =C5&" "&D5&" "&E5


Комментарии
Только для авторизованных пользователей

(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved