Подсчет слов в ячейке в EXCEL

Файл примера

Для подсчета количества слов в ячейке используем функции ДЛСТР() , СЖПРОБЕЛЫ() и ПОДСТАВИТЬ() .


Пусть ячейка A1 содержит текст « Желаю приятно провести время !».

Для подсчета в ней слов запишем формулу (см. файл примера )

= ЕСЛИ(ДЛСТР(СЖПРОБЕЛЫ(A1))=0;0; ДЛСТР(СЖПРОБЕЛЫ(A1))-ДЛСТР(ПОДСТАВИТЬ(A1;" ";""))+1)

Формула возвращает значение 4, означающее, что в ячейке содержится четыре слова, разделенные пробелами. При этом не имеет значения, разделены ли слова несколькими пробелами, или слова начинаются или заканчиваются пробелами. Функция СЖПРОБЕЛЫ() удаляет лишние пробелы, пробелы в начале и в конце текста в ячейке.

Также формула проверяет есть ли полезная информация в ячейке: ДЛСТР(СЖПРОБЕЛЫ(A1))=0 .

Файл примера

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved