Подсчет количества выходных дней в диапазоне дат EXCEL

Подсчитаем количество выходных дней, содержащихся в диапазоне дат. Даты введены в ячейки листа. Выходными днями считаются суббота и воскресенье (праздники не учитываются).


Пусть дан перечень дат (не обязательно идут подряд).

Формула =СУММПРОИЗВ(--(ДЕНЬНЕД(A6:A15;2)>5)) подсчитает количество выходных в диапазоне A6:A15 (см. файл примера ).

Если необходимо подсчитать количество выходных для подрят идущих дат, начиная с определенной даты, то используйте формулу

=СУММПРОИЗВ(--(ДЕНЬНЕД(A22+СТРОКА(ДВССЫЛ("A1:A"&B22))-1;2)>5))

Предполагается, что в А22 введена начальная дата, а в В22 - количество значений. Выражение СТРОКА(ДВССЫЛ("A1:A"&B22)) задает массив последовательных чисел , начиная с 1. Далее к начальной дате последовательно прибавляется 1, 2 и т.д., т.е. формируется диапазон подряд идущих дат.


© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved