Переворачиваем столбец в EXCEL

Научимся с помощью формул переворачивать в MS EXCEL столбец вверх ногами (чтобы данные расположенные в последних строках стали отображаться первыми).


Пусть имеется столбец с данными (Исходный столбец (столбец А)). В первой ячейке столбца ( А7 ) содержится значение 10, а в последней ( А16 ) - значение 100.

С помощью формулы

=СМЕЩ($A$16;(СТРОКА($A$7)-СТРОКА());)

в соседнем столбце получим перевернутый столбец (введите эту формулу в ячейку В7 и протяните ее вниз с помощью Маркера заполнения ).

Примечание : Исходный столбец и формулу можно найти в файле примера .

Аналогичного результата можно добиться с помощью формулы

=ИНДЕКС($A$7:$A$16;ЧСТРОК(A7:$A$16))

Подробнее о работе использованных функций можно прочитать кликнув на соответствующие ссылки внизу статьи на вкладке Использованные функции (под кнопкой Скачать файл примера ).

Примечание : Чтобы повернуть столбец, т.е. транспонировать его, см. статью Транспонирование таблиц в MS EXCEL .


© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved