Округляем до ближайшего ЧИСЛА, кратного заданному (четному, нечетному) в EXCEL

Округлить с точностью до 0,01; 0,1; 1; 10; 100 не представляет труда – для этого существует функция ОКРУГЛ() . А если нужно округлить, например, до ближайшего числа, кратного 50?


В EXCEL 2007 функция ОКРУГЛТ(число;точность) поможет округлить с необходимой точностью (не путать с функцией ОКРУГЛ() , см. статью Функция ОКРУГЛ() в MS EXCEL ).

Число и точность должны быть одного знака (либо оба положительные или оба отрицательные), иначе функция возвращает ошибку #ЧИСЛО!

Примеры Округляем до ближайшего числа, кратного 50: =ОКРУГЛТ(102;50) – результат 100; =ОКРУГЛТ(124,999;50) – результат 100; =ОКРУГЛТ(125;50) – результат 150.

Альтернативный вариант с функцией ОКРУГЛ() =ОКРУГЛ(124,999/50;0)*50

Округление до ближайшего четного (см. Файл примера ): =ОКРУГЛТ(A2;2) или = ЦЕЛОЕ(A2/2+0,5)*2

Округление до нечетного: =ОКРУГЛТ(A2-1;2)+1 или =ЦЕЛОЕ((A2-1)/2+0,5)*2+1

Об округлении времени читайте в статье Округление времени с заданной точностью .


Комментарии
Только для авторизованных пользователей

Аноним, 9 июня 2016 г.
Спасибо! Чётко и понятно! 8)
Аноним, 14 мая 2018 г.
Все понятно
Аноним, 30 апреля 2020 г.
А если нужно округлить до 50, но в большую сторону?
Михаил, 30 апреля 2020 г.
для этого есть специальная функция =ОКРВВЕРХ(A4;50)
(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved