Функция СРЗНАЧЕСЛИ() - Вычисление в MS EXCEL среднего по условию (один ЧИСЛОвой критерий)

Найдем среднее всех ячеек, значения которых соответствуют определенному критерию. Для этой цели существует простая и эффективная функция СРЗНАЧЕСЛИ(), английский вариант AVERAGEIF(), которая впервые появилась в EXCEL 2007.

Синтаксис функции

СРЗНАЧЕСЛИ(Диапазон; Условие; [Диапазон_усреднения])

Диапазон   — диапазон ячеек, в котором ищутся значения соответствующие аргументу Условие. Диапазон может содержать числа, даты, текстовые значения или ссылки на другие ячейки. В случае, если другой аргумент - Диапазон_усреднения - опущен, то аргумент Диапазон должен содержать числа.

Условие   — критерий в форме числа, выражения или текста, определяющий, какие ячейки должны участвовать в вычислении среднего. Например, аргумент Условие может быть выражен как 32, "яблоки" или ">32".

Диапазон_усреднения  — диапазон ячеек содержащий числа, участвующие в вычислении среднего, в случае если соответствующие им ячейки, указанные в аргументе Диапазон соответствуют аргументу Условие.Диапазон_усреднения- необязательный аргумент. Если он опущен, то вычисление среднего будет производиться по диапазону ячеек, указанному в аргументе Диапазон.

Примеры

Рассмотрим случай, когда аргумент Диапазон_усредненияопущен. В этом случае вычисление среднего будет производиться по диапазону ячеек, указанному в первом аргументе Диапазон (т.е. он должен содержать числа). В нем же будет производиться поиск значений соответствующих аргументу Условие, которые затем и будут участвовать в вычислении среднего. Пусть это будет диапазон A5:A15, см. Файл примера.

Решим задачи:

  • найти среднее всех чисел менее или равных заданному (10): =СРЗНАЧЕСЛИ(A5:A15;"<=10").
  • найти среднее всех положительных чисел в диапазоне: =СРЗНАЧЕСЛИ(A5:A15;">0"). Другой вариант с использованием функции СУММПРОИЗВ(): =СУММПРОИЗВ((A5:A15)*(A5:A15>0))/ СЧЁТЕСЛИ(A5:A15;">=10")

Форма задания критерия достаточно гибка. Например, в файле примера в формуле =СРЗНАЧЕСЛИ(A5:A15;C7&C8) критерий >=10 задан через ссылку C7&C8: в С7 содержится текстовое значение >=, а в С8 – число 10. Пользователь может легко изменить критерий.

СОВЕТ:
В статье Вычисление среднего по условию (один Текстовый критерий) рассмотрен более общий случай, когда критерий применяется к соседнему диапазону, содержащему текстовые значения, а суммирование производится только соответствующих ячеек из числового диапазона.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4.4 (7 оценок)