Функция СЧИТАТЬПУСТОТЫ() в EXCEL

Функция СЧИТАТЬПУСТОТЫ( ) , английская версия COUNTBLANK() , подсчитывает количество пустых ячеек в заданном диапазоне. Также она подсчитывает ячейки с формулами, результатом вычисления которых является значение Пустой текст "" (например, =ЕСЛИ(1=1;"";1000) )


Синтаксис

СЧИТАТЬПУСТОТЫ(диапазон)

Диапазон — Диапазон ячеек, в котором требуется подсчитать количество пустых ячеек.

Ячейки с формулами, которые возвращают значение "" ( Пустой текст ), также учитываются при подсчете. Ячейки с нулевыми значениями не учитываются.

Также для использования этой функции нужно отключить итеративные вычисления, для этого:

  1. Нажмите Кнопку Офис и выберите команду Параметры Excel ( внизу окна ) .
  2. На вкладке Формулы в разделе Параметры вычислений снимите флажок Включить итеративные вычисления и нажмите кнопку ОК .

Ниже приведена таблица с двумя диапазонами. В первом диапазоне (см. столбец А ) имеются 2 пустые ячейки и они подсчитываются формулой =СЧИТАТЬПУСТОТЫ(A7:A12) (см. файл примера ).

Во втором столбце пустых ячеек нет , но есть формула =ЕСЛИ(B7=10;"";1000) , возвращающая значение Пустой текст "", которое также подсчитывается функцией СЧИТАТЬПУСТОТЫ() .

Чтобы подсчитать действительно пустые ячейки читайте статью Подсчет пустых ячеек .


© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved