Функция НАЙТИ() в EXCEL

Функция НАЙТИ( ) , английский вариант FIND(), находит первое вхождение одной текстовой строки в другой строке и возвращают начальную позицию найденной строки.


Синтаксис функции

НАЙТИ ( искомый_текст ; просматриваемая_строка ;[нач_позиция])

Искомый_текст — текст, который требуется найти.

Просматриваемая_строка — текст, в которой ищется Искомый_текст .

Нач_позиция — позиция знака в просматриваемой_строке, с которой должен начинаться поиск. Если аргумент нач_позиция опущен, то предполагается значение 1.

Если искомый_текст не найден, возвращается значение ошибки #ЗНАЧ!

Функция НАЙТИ() учитывает РЕгиСТР букв, т.е. результат поиска в строке " ПЕРВЫЙ первый " будет разным для формул =НАЙТИ("ПЕРВЫЙ";"ПЕРВЫЙ первый") и =НАЙТИ("первый";"ПЕРВЫЙ первый") . Первая вернет 1, вторая 8.

Примеры



Формула =НАЙТИ("к";"Первый канал") вернет 8, т.к. буква к находится на 8-й позиции слева. Формула =НАЙТИ("К";"Первый канал") вернет значение ошибки #ЗНАЧ!, т.к. с учетом регистра строка Первый канал не содержит букву К .

Пусть в ячейке А2 введена строка Первый канал - лучший . Формула =НАЙТИ(СИМВОЛ(32);A2) вернет 7, т.к. символ пробела (код 32) находится на 7-й позиции.

Чтобы найти позицию второго вхождения буквы "а" в строке "мама мыла раму" используйте формулу =НАЙТИ("а";"мама мыла раму";НАЙТИ("а";"мама мыла раму")+1). Чтобы определить есть ли третье вхождение буквы "м" в строке "мама мыла раму" используйте формулу =ЕСЛИ(ДЛСТР(ПОДСТАВИТЬ("мама мыла раму";"м";"";3))=ДЛСТР("мама мыла раму");"Нет третьего вхождения";"Есть третье вхождение") .

Функция НАЙТИ() vs ПОИСК()

Функция НАЙТИ() учитывает РЕгиСТР букв и не допускает использование подстановочных знаков . Для поиска без учета регистра, а также для поиска с использованием подстановочных знаков пользуйтесь функцией ПОИСК() .

Связь с функциями ЛЕВСИМВ() , ПРАВСИМВ() и ПСТР()

Функция НАЙТИ() может быть использована совместно с функциями ЛЕВСИМВ() , ПРАВСИМВ() и ПСТР() .

Например, в ячейке А2 содержится фамилия и имя "Иванов Иван", то формула =ЛЕВСИМВ(A2;НАЙТИ(СИМВОЛ(32);A2)-1) извлечет фамилию, а =ПРАВСИМВ(A2;ДЛСТР(A2)-НАЙТИ(СИМВОЛ(32);A2)) - имя. Если между именем и фамилией содержится более одного пробела, то для работоспособности вышеупомянутых формул используйте функцию СЖПРОБЕЛЫ() .


Комментарии
Только для авторизованных пользователей

(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved