Ближайший рабочий день в EXCEL

Предположим, что счет за продукцию нужно выставлять только в рабочие дни, несмотря на дату доставки. Напишем формулу, которая определяет: если дата доставки попадает на выходной, то дата счета – следующий понедельник (или прошедшая пятница).


Если дата (ячейка A 2 ) попадает на субботу или воскресенье, то нижеследующая формула возвращает дату следующего понедельника (см. Файл примера ): =РАБДЕНЬ(A2-1;1) или

=ЕСЛИ(ДЕНЬНЕД(A2;2)>5;A2+(8-ДЕНЬНЕД(A2;2));A2)

или дату прошедшей пятницы =ЕСЛИ(ДЕНЬНЕД(A2;2)>5;МИН(A2-(ДЕНЬНЕД(A2;2)-5);A2);A2)

Если дата попадает на воскресенье, то будет возвращена прошедшая суббота: =ЕСЛИ(ДЕНЬНЕД(A2;2)>6;A2-1;A2)

Если дата попадает на воскресенье, то будет возвращен следующий понедельник: =ЕСЛИ(ДЕНЬНЕД(A2;2)>6;A2+1;A2)

ВНИМАНИЕ! Формулы не учитывают праздничные дни и переносы рабочих дней на выходные. В статье Ближайший рабочий день с учетом праздников и переносов учтены праздничные дни и переносы рабочих дней на выходные.


Комментарии
Только для авторизованных пользователей

(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved