Выделяем дни недели цветом в MS EXCEL

С помощью Условного форматирования выделим фон ячеек, содержащих дни недели Суббота и Воскресенье, красным цветом.

Пусть в столбце А содержится перечень дат. Выделим ячейки, содержащие дни недели Суббота и Воскресенье, красным цветом (см. файл примера).

Выделять ячейки будем с помощью правил Условного форматирования. В зависимости от содержимого ячейки (дата, текст или число) правила будут разными.

В ячейке содержится Дата

В столбце А содержатся значения в формате дата, например в ячейке А6 - 13.08.2012.

Чтобы настроить правило Условного форматирования нужно:

  • выделить диапазон А6:А14
  • выбрать пункт меню Главная/ Стили/ Условное форматирование/ Создать правило...
  • выбрать тип правила Использовать формулу для определения форматируемых ячеек
  • в поле Форматировать значения, для которых следующая формула является истинной ввести формулу =ДЕНЬНЕД(A6;2)>5
  • задать формат, например красную заливку фона ячейки.

Даты в столбце А, у которых номер дня недели >5, будут выделены красным.

В ячейке с пользовательским форматом ДДД или ДДДД содержится Дата

Пусть в столбцах B и С также содержатся значения в формате дата, например в ячейке B6 введем формулу =A6.

Для ячеек в диапазоне B6:B14 настроим пользовательский формат ДДД (для диапазона С6:С14 ДДДД).

Не смотря на то, что теперь в ячейках отображаются Пн и Понедельник, значения в ячейках продолжают оставаться в формате Дата. В этом можно убедиться скопировав значение (CTRL+V), например, из ячейки С6, и вставив его Как значение (Главная/ Буфер обмена/ Вставить / Вставить значение). В Строке формул будет отображаться значение 13.08.2012, а не слово понедельник. Поэтому настраивать правило Условного форматирования нужно так как показано в предыдущем разделе.

В ячейке содержится Число

Пусть в столбце D содержится номер дня недели, например в ячейке D6 введем формулу =ДЕНЬНЕД(A6;2).

В этом случае правило Условного форматирования настраивается аналогично случаю когда в ячейке содержится Дата, только несколько упрощается формула =$D6>5

В ячейке содержится Текстовое значение

Пусть в столбце E содержится день недели в текстовом формате, например слово Понедельник.

В этом случае правило Условного форматирования настраивается с помощью формулы =ИЛИ($E6="суббота";$E6="воскресенье")


Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (3 оценок)

Комментарии

Миша (не проверено)

Спасибо!

алексей (не проверено)

Если дату 21.12.2013 узнать день недели, выдает субботу (правильно), если ячейку перевести в числовой то пишет 41629, но ни как не 1,2,3 ...7. Excel 2013

Creator

Алексей, 41629 - это числовая запись соответствующая 21/12/2013. Об этом читайте в статье http://excel2.ru/articles/kak-excel-hranit-datu-i-vremya В столбце D используется функция ДЕНЬНЕД(), которая позволяет как раз дату 21/12/2013 (т.е. число 41629) превратить в день недели (число 6).

Павел (не проверено)

Это работает, по-видимому, на русском офисе.

На английском неделя начинается с воскресенья и заканчивается субботой.

Так что там работает формула =OR(WEEKDAY(A6:A14)>6,WEEKDAY(A6:A14)<2)

При переходе между офисами, вероятно, работать будет некорректно.

Creator

Функция ДЕНЬНЕД() или WEEKDAY() в качестве первого аргумента принимает значение с одной датой. Если Вы вводите целый массив (ссылку), то во-первых нельзя использовать функцию ИЛИ(), вместо нее используйте оператор +, а во-вторых формулу скорее всего нужно вводить как формулу массива. "При переходе между офисами" все, естественно, будет работать корректно: если нужно задать, чтобы неделя начиналась с понедельника используйте второй аргумент тип со значением 2. 

Ваша формула в русском офисе будет выглядеть так: =СУММПРОИЗВ((ДЕНЬНЕД(A6:A14)>6)+(ДЕНЬНЕД(A6:A14)<2)) - количество суббот и воскресений в диапазоне A6:A14. или так =СУММПРОИЗВ(--(ДЕНЬНЕД(A6:A14;2)>5))

Яндекс.Метрика