Суммирование ЧИСЕЛ соответствующих неповторяющимся значениям в MS EXCEL

Пусть дана таблица с двумя столбцами: текстовый столбец с повторами и числовой столбец. Просуммируем только те числа, которые соответствуют неповторяющимся текстовым значениям.

Пусть исходная таблица содержит 2 столбца: текстовый – Список регионов и числовой - Объем продаж (см. файл примера)

Столбец Список регионов содержит повторяющиеся значения (Азия и Южная Америка). Неповторяющимися значениями соответственно являются: Европа, США, Россия, Австралия, Китай. В файле примера выделены Условным форматированием только повторяющиеся значения.

Задача

Необходимо найти сумму чисел из столбца B, соответствующих неповторяющимся значениям (в решении использованы идеи, изложенные в статье Отбор неповторяющихся значений со значениями из соседнего столбца).

Решение

Решим задачу с помощью формулы массива:
=СУММ(ЕСЛИ(СЧЁТЕСЛИ(Регионы;Регионы)=1;Продажи;0))

Будут сложены только числа соответствующие регионам Европа, США, Россия, Австралия, Китай.

Регионы - это Динамический диапазон, содержащий список Регионов, сформированный формулой =СМЕЩ(лист1!$A$2;;;СЧЁТЗ(лист1!$A$2:$A$12)), а Продажи - это динамический диапазон, содержащий список Объемов продаж.

Если в исходную таблицу будут вводиться данные, то границы диапазона Регионы изменятся в зависимости от количества введенных значений в столбец А (пропуски не допускаются).

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (1 оценка)