Совпадают ли 2 списка в MS EXCEL? (попарное совпадение)

Пусть дано 2 списка ЧИСЛОвых значений. Определим, совпадают ли эти 2 списка (критерий сравнения: попарное совпадение элементов).

Пусть Список1 находится в диапазоне A2:A10, Список2 - в диапазоне B2:B10.

Определим совпадают ли два списка. Списки будут считаться совпадающими, если имеет место попарное совпадение элементов. Т.е. списки {1, 2, 3} и {1, 2, 3} будут считаться совпадающими, а {1, 2, 3} и {3, 2, 1} – различными.

Для определения совпадения используем формулу (см. Файл примера):
=СУММПРОИЗВ(--(A2:A10<>B2:B10))

Формула попарно сравнивает элементы каждого списка (A2:A10<>B2:B10). Если различия не обнаружены (везде получено значение ЛОЖЬ), то сумма этих значений =0 (ЛОЖЬ в арифметических значениях заменяется нулем), и соответственно, списки совпадают.

То есть, если 2 списка состоят из разных элементов или из одинаковых элементов, но списки отсортированы по-разному, то списки считаются не совпадающими. Поэтому списки перед сравнением нужно отсортировать.

Аналогичное сравнение можно осуществить без использования формул, например с помощью инструмента Выделение группы ячеек (см. раздел Отличия по строкам) или с использованием очевидных формул в дополнительном столбце.

СОВЕТ:
Более подробное сравнение 2-х списков описано в статье Сравнение 2-х списков.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4.5 (2 оценок)