Преобразование в MS EXCEL ТЕКСТовых значений в ДАТУ

Бывает, что при экспорте значений в EXCEL, даты записываются в незнакомом для EXCEL формате, например 20081223 (т.е. 2008г, 23 декабря). Для дальнейшей работы с такими датами выполним преобразование в привычный для EXCEL формат даты.

Предположим, в A1 введена дата в виде 20081223. Выполним преобразование в формат даты EXCEL.

С использованием функции ДATA()
=ДАТА(ЛЕВСИМВ(A1;4);ПСТР(A1;5;2);ПРАВСИМВ(A1;2))

С использованием пользовательского формата
=ТЕКСТ(A1;"0000""/""00""/""00")+0

Или так

=--ТЕКСТ(A1;"0000\/00\/00")

Обратный слеш (\) нужен для корректного отображения слеша (/). Функция ТЕКСТ() возвращает текстовое значение, а применение математических операций +0 или два минуса (--), заставляют EXCEL попытаться перевести текст в подходящий числовой формат или дату, не изменяя результата.(см. файл примера).

Так как форматов представления даты существует бесчисленное множество (01012011, 2011,01,01 и пр.), то для каждого случая придется создавать отдельную формулу. Конечно, перед этим стоит проверить, может ли значение быть преобразовано в ДАТУ стандартными средствами EXCEL.

СОВЕТ:
О пользовательском форматировании для дат читайте в статье Пользовательский формат.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (3 оценок)