Подстановочные знаки в MS EXCEL

Подстановочные знаки (* и ?) можно использовать в Условном форматировании, условиях отбора Расширенного фильтра, в ряде функций, а также при поиске и замене ТЕКСТовых значений штатными средствами EXCEL.

Если имеется диапазон с текстовыми значениями и необходимо произвести поиск или подсчет этих значений на основании какого-нибудь критерия, то использование подстановочных знаков (* и ?) существенно расширяет возможности поиска.

Подстановочный знак ? (знак вопроса) означает один любой символ, а знак * (звездочка) - последовательность символов любой длины.

Используйте

Чтобы найти

? (знак вопроса)

Один из символов
Пример: условию «бар?н» соответствуют результаты «барин», «барон» и «баран»

* (звездочка)

Любое количество символов
Пример: условию «*-восток» соответствуют результаты «северо-восток» и «юго-восток»

~ (тильда), за которой следует ?, * или ~

Вопросительный знак, звездочку или тильду.
Пример: по условию поиска «ан06~?» будет найдено «ан06?»

Использование в функциях

Предположим, что стоит задача подсчета ячеек, содержащих все склонения слова молоток (например, молотку, молотком, молотка и пр.). Для решения этой задачи проще всего использовать критерии отбора с подстановочным знаком * (звездочка). Идея заключается в следующем: для условий отбора текстовых значений можно задать в качестве критерия лишь часть текстового значения (для нашего случая, это – молот), а другую часть заменить подстановочными знаками. В нашем случае, критерий будет выглядеть так – молот*.

Предполагая, что текстовые значения (склонения слова молот) находятся в диапазоне А2:А10, запишем формулу =СЧЁТЕСЛИ(A2:A10;"молот*")). В результате будут подсчитаны все склонения слова молоток в диапазоне A2:A10.

Нижеследующие функции позволяют использовать подстановочные знаки:

Описание применения подстановочных знаков в вышеуказанных функциях описано соответствующих статьях.

Использование в инструменте Найти…

Также подстановочные знаки можно использовать в стандартном инструменте Найти… (Главная/ Редактирование/ Найти и выделить/ Найти… или нажать CTRL+F)

На рисунке выше показано, как найти ячейки, содержащие слово из пяти букв, первые 4 из которых фраза "дрел".

Использование в Расширенном фильтре

Использование подстановочных знаков в Расширенном фильтре описано в этой статье.

Использование в Условном форматировании

Использование подстановочных знаков в правилах Условного форматирования описано в этой статье.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (6 оценок)
Яндекс.Метрика