Отображение широты и долготы в MS EXCEL

Если Вам нужно отобразить широту или долготу в формате 56°54'31" (56 градусов 54 минуты 31 секунда), то этот пример для Вас.

В зависимости от желаемого результата и исходных данных существуют разные способы отображения широты и долготы в формате 56°54'31" (56 градусов 54 минуты 31 секунда).

Применение пользовательского формата

Если в ячейке содержится число вида 565431, то применение пользовательского формата позволит только правильно отобразить формат широты и долготы (56°54'31"), арифметические же операции с долготой или шириной произвести не удастся (при прибавлении 30 секунд будем иметь 56°54'61", а не 56°55'01"). Тем не менее, применим пользовательский формат.

Пользовательский формат вводим через диалоговое окно Формат ячеек. Для вызова окна нажмите CTRL+1. Выберите (все форматы), удалите все из поля Тип.

  • в поле Тип введите ###;
  • затем введите туда же знак градуса (°), скопировав из Буфера обмена, в который его заранее туда вставили командой Символ (Вставка/ Текст/ Символ). Или удерживая ALT, наберите на цифровой клавиатуре 0176 и отпустите ALT (Подробнее о вводе нестандартных символов читайте в статье Ввод символов с помощью клавиши ALT);
  • введите пробел, два нуля, апостроф (‘) и еще пробел;
  • введите еще два нуля и еще 2 апострофа (‘) (двойная кавычка не подойдет или ее придется вводить вместе с обратным слешем \");
  • нажмите ОК.

Теперь введите в ячейку 565431 и нажмите ENTER, в ячейке отобразится 56°54'31".

Преобразование из десятичного формата

Часто долготу и широту представляют в десятичном формате. Например, число 122,44 соответствует 122 градусам 26 минутам и 24 секундам. Проверить это не составляет труда: целая часть соответствует градусам, 1 градус соответствует единице, минута– 1/60 градуса, секунда – 1/60 минуты или 1/3600 градуса. Получаем: 122+26*(1/60)+24*(1/3600)=122,44.

С десятичным представлением можно производить необходимые вычисления, например, можно прибавить 2 минуты и 10 секунд: +2*(1/60)+10*(1/3600).

Представить 122,44 в формате долготы и широты с помощью простого форматирования не удастся, нужно использовать формулу для преобразования из десятичного формата. Если значение долготы 122,44 находится в ячейке А1, то для преобразования в нужный формат запишем формулу:
=ТЕКСТ(ОТБР(A1);"0"&СИМВОЛ(176))
&ТЕКСТ(ЦЕЛОЕ(ОСТАТ(A1;1)*60);"0'")
&ТЕКСТ(60*ОСТАТ((ОСТАТ(A1;1)*60);1);"0' ")

Результат: 122°26'24''– значение в текстовом формате.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (4 оценок)
Яндекс.Метрика