Отбор четных и нечетных строк таблицы в MS EXCEL

Для извлечения из таблицы только четных или нечетных строк можно использовать формулы и Автофильтр

Пусть имеется исходная таблица с объемами продаж товаров по кварталам. 

Нам требуется отобразить только четные или нечетные строки.

Примечание: О выделении нечетных строк Условным форматированием читайте в статье о Чрезстрочном выделении.

Автофильтр

Это можно легко сделать с помощью Автофильтра в столбце F. Для этого в ячейку F8 введите формулу =ЕЧЁТН(СТРОКА()-СТРОКА($F$7)) и скопируйте ее вниз. Формула для четных строк таблицы (не листа!) возвращает ИСТИНА.

Теперь с помощью Автофильтра можно выбрать либо четные либо нечетные строки.

Формулы

Выведем четные и нечетные строки с помощью формул.

С помощью формулы =ИНДЕКС(A$8:A$17;(СТРОКА()-СТРОКА($A$21))*2) можно отобрать только четные строки из исходной таблицы.

С помощью формулы =ИНДЕКС(A$8:A$17;(СТРОКА()-СТРОКА($A$30))*2-1) можно отобрать только нечетные строки.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4.7 (3 оценок)