Именованный диапазон в MS EXCEL

Обычно ссылки на диапазоны ячеек вводятся непосредственно в формулы, например =СУММ(А1:А10). Другим подходом является использование в качестве ссылки имени диапазона. В статье рассмотрим какие преимущества дает использование имени.

Назовем Именованным диапазоном в MS EXCEL, диапазон ячеек, которому присвоено Имя (советуем перед прочтением этой статьи ознакомиться с правилами создания Имен).

Преимуществом именованного диапазона является его информативность. Сравним две записи одной формулы для суммирования, например, объемов продаж: =СУММ($B$2:$B$10) и =СУММ(Продажи). Хотя формулы вернут один и тот же результат (если, конечно, диапазону B2:B10 присвоено имя Продажи), но иногда проще работать не напрямую с диапазонами, а с их именами.

Совет: Узнать на какой диапазон ячеек ссылается Имя можно через Диспетчер имен расположенный в меню  Формулы/ Определенные имена/ Диспетчер имен.

Ниже рассмотрим как присваивать имя диапазонам. Оказывается, что диапазону ячеек можно присвоить имя по разному: используя абсолютную или смешанную адресацию.

Задача1 (Именованный диапазон с абсолютной адресацией)

Пусть необходимо найти объем продаж товаров (см. файл примера лист 1сезон):

Присвоим Имя Продажи диапазону B2:B10. При создании имени будем использовать абсолютную адресацию.

Для этого:

  • выделите, диапазон B2:B10 на листе 1сезон;
  • на вкладке Формулы в группе Определенные имена выберите команду Присвоить имя;
  • в поле Имя введите: Продажи;
  • в поле Область выберите лист 1сезон (имя будет работать только на этом листе) или оставьте значение Книга, чтобы имя было доступно на любом листе книги;
  • убедитесь, что в поле Диапазон введена формула ='1сезон'!$B$2:$B$10
  • нажмите ОК.

Теперь в любой ячейке листа 1сезон можно написать формулу в простом и наглядном виде: =СУММ(Продажи). Будет выведена сумма значений из диапазона B2:B10.

Также можно, например, подсчитать среднее значение продаж, записав =СРЗНАЧ(Продажи).

Обратите внимание, что EXCEL при создании имени использовал абсолютную адресацию $B$1:$B$10. Абсолютная ссылка жестко фиксирует диапазон суммирования: в какой ячейке на листе Вы бы не написали формулу =СУММ(Продажи) – суммирование будет производиться по одному и тому же диапазону B1:B10.

Иногда выгодно использовать не абсолютную, а относительную ссылку, об этом ниже.

Задача2 (Именованный диапазон с относительной адресацией)

Теперь найдем сумму продаж товаров в четырех сезонах. Данные о продажах находятся на листе 4сезона (см. файл примера) в диапазонах: B2:B10, C2:C10, D2:D10, E2:E10. Формулы поместим соответственно в ячейках B11, C11, D11, E11.

По аналогии с абсолютной адресацией из предыдущей задачи, можно, конечно, создать 4 именованных диапазона с абсолютной адресацией, но есть решение лучше. С использованием относительной адресации можно ограничиться созданием только одного Именованного диапазона Сезонные_продажи.

Для этого:

  • выделите ячейку B11, в которой будет находится формула суммирования (при использовании относительной адресации важно четко фиксировать нахождение активной ячейки в момент создания имени);
  • на вкладке Формулы в группе Определенные имена выберите команду Присвоить имя;
  • в поле Имя введите: Сезонные_Продажи;
  • в поле Область выберите лист 4сезона (имя будет работать только на этом листе);
  • убедитесь, что в поле Диапазон введена формула ='4сезона'!B$2:B$10
  • нажмите ОК.

Мы использовали смешанную адресацию B$2:B$10 (без знака $ перед названием столбца). Такая адресация позволяет суммировать значения находящиеся в строках 2, 3,…10, в том столбце, в котором размещена формула суммирования. Формулу суммирования можно разместить в любой строке ниже десятой (иначе возникнет циклическая ссылка).

Теперь введем формулу =СУММ(Сезонные_Продажи) в ячейку B11. Затем, с помощью Маркера заполнения, скопируем ее в ячейки С11, D11, E11, и получим суммы продаж в каждом из 4-х сезонов. Формула в ячейках B11, С11, D11 и E11 одна и та же!

СОВЕТ:
Если выделить ячейку, содержащую формулу с именем диапазона, и нажать клавишу F2, то соответствующие ячейки будут обведены синей рамкой (визуальное отображение Именованного диапазона).

Использование именованных диапазонов в сложных формулах

Предположим, что имеется сложная (длинная) формула, в которой несколько раз используется ссылка на один и тот же диапазон:

=СУММ(E2:E8)+СРЗНАЧ(E2:E8)/5+10/СУММ(E2:E8)

Если нам потребуется изменить ссылку на диапазон данных, то это придется сделать 3 раза. Например, ссылку E2:E8 поменять на J14:J20.

Но, если перед составлением сложной формулы мы присвоим диапазону E2:E8 какое-нибудь имя (например, Цены), то ссылку на диапазон придется менять только 1 раз и даже не в формуле, а в Диспетчере имен!

=СУММ(Цены)+СРЗНАЧ(Цены)/5+10/СУММ(Цены)

Более того, при создании формул EXCEL будет сам подсказывать имя диапазона! Для этого достаточно ввести первую букву его имени.

 

Excel добавит к именам формул, начинающихся на эту букву, еще и имя диапазона!

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4 (15 оценок)

Комментарии

erikbond

Возможно ли в диспетчере имен копировать именованные формулы?

Creator

Кнопки такой нет. Но, можно выделить нужное имя, скопировать его формулу в буфер обмена. Затем создать новое имя и вставить в поле Диапазон скопированную формулу.

А вот удалять можно сразу несколько имен. Достаточно их выделить в Диспетчере задач и нажать удалить.