Отбор повторяющихся значений с помощью фильтра MS EXCEL

Из исходной таблицы с повторяющимися значениями отберем с помощью фильтра только те значения, которые имеют повторы.

Пусть в столбце А имеется список с повторяющимися значениями, например список с названиями компаний. В некоторых ячейках исходного списка имеются повторы. Повторяющиеся значения выделены с помощью Условного форматирования.

 

Задача

Отберем только те значения, которые имеют повторы.

Решение

Напротив первого значения в исходном списке, в столбце В запишем формулу =СЧЁТЕСЛИ($A$5:$A$19;A5)

Скопируем формулу Маркером заполнения в ячейки ниже.

Как видно, напротив повторяющихся значений в столбце В стоит значение >1.

Выделим заголовок таблицы и нажмем (CTRL+SHIFT+L), т.е. вызовем фильтр.

В фильтре установим критерий отбора для столбца В.

Скопируем отобранные значения вместе с заголовком в отдельный диапазон или лист. Выделим скопированные значения и через меню Данные / Работа с данными / Удалить дубликаты удалим ненужные повторы.

В итоге получим список значений, которые в исходном списке имеют повторы.

СОВЕТ:

Созданный список повторяющихся значений не является динамическим, т.е. при добавлении новых значений в исходный список, список повторов нужно будет создавать заново. Это неудобно. Если требуется создать динамический список повторов, то см. статью Отбор повторяющихся значений.

Промежуточным вариантом является использование Сводной таблицы.

После добавления новых значений в исходный список теперь достаточно обновить Сводную таблицу - список значений, которые имеют повторы, обновится (см. файл примера).

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (2 оценок)
Яндекс.Метрика