Функция СУММЕСЛИ() - Сложение с одним критерием в MS EXCEL (Часть1.ЧИСЛОвой критерий)

Для суммирования значений, удовлетворяющих заданному критерию (условию), используется функция СУММЕСЛИ(), английская версия SUMIF().

Синтаксис функции

СУММЕСЛИ(Диапазон; Условие; [Диапазон_суммирования])

Диапазон   — диапазон ячеек, в котором ищутся значения соответствующие аргументу Условие. Диапазон может содержать числа, даты, текстовые значения или ссылки на другие ячейки. В случае, если другой аргумент - Диапазон_суммирования - опущен, то аргумент Диапазон также является диапазоном, по которому производится суммирование значений удовлетворяющих аргументу Условие (в этом случае Диапазон должен содержать числа).

Условие   — критерий в форме числа, выражения или текста, определяющий, какие ячейки должны суммироваться. Например, аргумент Условие может быть выражен как 32, "яблоки" или ">32".

Диапазон_суммирования  — диапазон ячеек содержащий числа, которые будут просуммированы, в случае если соответствующие им ячейки, указанные в аргументе Диапазон соответствуют аргументу Условие. Диапазон_суммирования - необязательный аргумент. Если он опущен, то суммирование будет производиться по диапазону ячеек, указанному в аргументе Диапазон.

Примеры

Рассмотрим случай, когда аргумент Диапазон_суммирования опущен. В этом случае суммирование будет производиться по диапазону ячеек, указанному в первом аргументе Диапазон (т.е. он должен содержать числа). В нем же будет производиться поиск значений соответствующих аргументу Условие, которые затем и будут просуммированы. Пусть это будет диапазон B5:B15, см. Файл примера.

Решим задачи:

  • найти сумму всех чисел больше или равных 10. Ответ: 175. Формула: =СУММЕСЛИ(B5:B15;">=10")
  • найти сумму всех чисел меньше или равных 10. Ответ: 42. Формула: =СУММЕСЛИ(B5:B15;"<=10")
  • найти сумму всех положительных чисел в диапазоне. Формула: =СУММЕСЛИ(B5:B15;">0"). Альтернативный вариант с использованием функции СУММПРОИЗВ() выглядит так : =СУММПРОИЗВ((B5:B15)*(B5:B15>0))

Форма задания условия (критерия) достаточно гибка. Например, в формуле =СУММЕСЛИ(B5:B15;D7&D8) критерий <=56 задан через ссылку D7&D8: в D7 содержится текстовое значение <=, а в D8 – число 56 (см. рисунок ниже). Пользователь, например, может легко изменить критерий с помощью Выпадающего списка в ячейке D7. Эквивалентная формула =СУММЕСЛИ(B5:B15;"<=56") или =СУММЕСЛИ(B5:B15;"<="&56) или =СУММЕСЛИ(B5:B15;"<="&D8) или =СУММЕСЛИ(B5:B15;D7&56).

СОВЕТ:

Для сложения с несколькими критериями воспользуйтесь статьей Функция СУММЕСЛИМН() Сложение с несколькими критериями в MS EXCEL (Часть 2.Условие И).

В статье СУММЕСЛИ - Сложение по условию (один Текстовый критерий) рассмотрен более общий случай, когда критерий применяется к соседнему диапазону, содержащему текстовые значения, а суммирование производится только соответствующих ячеек из числового диапазона.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (2 оценок)

Комментарии

TMP

Спасибо!

Оксана (не проверено)

Толково! Спасибище!

Антон (не проверено)

Как задать критерий "пустая ячейка"?

Creator

=СУММЕСЛИ(A1:A4;"";B1:B4)

Пустые ячейки лучше всегда заполнять, о том как это сделать быстро читайте здесь http://excel2.ru/articles/bystryy-vvod-odinakovyh-znacheniy

 

Екатерина (не проверено)

Как задать 2 текстовых критерия?

Creator


Для сложения с несколькими критериями воспользуйтесь статьей Функция СУММЕСЛИМН() Сложение с несколькими критериями в MS EXCEL (Часть 2.Условие И).

Юрий (не проверено)

Можно в качестве критерия использовать диапазон из дат, например с 01.01.01 по 31.01.01

Creator

 Да, конечно, т.к. каждой дате в EXCEL соответствует число, например, см. в статье Как Excel хранит дату и время. Дату можно задать непосредственно в формуле =СУММЕСЛИМН(B1:B10;A1:A10;">=1.1.2001";A1:A10;"<=31.1.2001") или через ссылку на ячейку с датой =СУММЕСЛИМН(B1:B10;A1:A10;">="&D1;A1:A10;"<="&E1). В формулах предполагается, что диапазон суммирования находится в столбце В, в столбце А - даты. В ячейках D1 и Е1 находятся Ваши граничные даты (критерии отбора). Вам нужна статья Сложение с несколькими критериями в MS EXCEL (Часть 1.Введение)

Яндекс.Метрика