ВПР

Сравнение 2-х таблиц в MS EXCEL

Сравним две таблицы имеющих практически одинаковую структуру. Таблицы различаются значениями в отдельных строках, некоторые наименования строк встречаются в одной таблице, но в другой могут отсутствовать.

Функция ПРОСМОТР() в MS EXCEL

Функция ПРОСМОТР(), английский вариант LOOKUP(), похожа на функцию ВПР(): ПРОСМОТР() просматривает левый столбец таблицы и, если находит искомое значение, возвращает значение из соответствующей строки самого правого столбца таблицы. Существенное ограничение использования функции ПРОСМОТР() - левый столбец исходной таблицы, по которому производится поиск, должен быть отсортирован по возрастанию, иначе получим непредсказуемый (вероятнее всего неправильный) результат.

Функция ПОИСКПОЗ() в MS EXCEL

Функция ПОИСКПОЗ(), английский вариант MATCH(), возвращает позицию значения в диапазоне ячеек. Например, если в ячейке А10 содержится значение "яблоки", то формула =ПОИСКПОЗ ("яблоки";A9:A20;0) вернет 2, т.е. искомое значение "яблоки" содержится во второй ячейке диапазона A9:A20:А9 - первая ячейка (предполагается, что в ней не содержится значение "яблоки"), А10 - вторая, А11 - третья и т.д. (подсчет позиции производится от верхней ячейки).

Функция ИНДЕКС() в MS EXCEL

Функция ИНДЕКС(), английский вариант INDEX(), возвращает значение из диапазона ячеек по номеру строки и столбца. Например, формула =ИНДЕКС(A9:A12;2) вернет значение из ячейки А10, т.е. из ячейки расположенной во второй строке диапазона.

Функция БИЗВЛЕЧЬ() в MS EXCEL

Функция БИЗВЛЕЧЬ(), английский вариант DGET(), извлекает из столбца (списка) или таблицы отдельное значение, удовлетворяющее заданным условиям.