Значение из Последней заполненной ячейки в MS EXCEL

Выведем значение из последней заполненной ячейки в списке. Список не должен содержать пропусков (пустых строк). Решение будет работать для числовых и текстовых списков.

Рассмотрим диапазон значений, в который регулярно заносятся новые данные. Пусть это будут курсы валют на определенную дату (см. файл примера).

Задача

Выведем в ячейки B3 и С3 последние котировки валют. Т.к. таблица постоянно пополняется, то необходимо написать формулу определяющую последнюю заполненную ячейку и вывести ее значение.

Решение

Как показано в статье Последняя заполненная ячейка значение последней заполненной ячейки в списке можно вывести с помощью формулы =ИНДЕКС(Список;СЧЁТЗ(Список))

Имя Список определяет Именованный диапазон с адресом B$7:B$25.

При определении адреса этого диапазона использована смешанная адресация, которая позволяет использовать этот диапазон для вывода значения последней заполненной ячейки в столбце B и в столбце С. При создании Именованного диапазона необходимо, чтобы активной ячейкой на листе была любая ячейка в столбце С.

Формулу поместим в ячейки B3 и С3. Вообще, формулу из-за наличия относительной адресации можно разместить только в строках 1-6 и ниже 25 в соответствующих столбцах (В и С).

Альтернативным вариантом является использование формул массива:

=ДВССЫЛ("B"&МАКС(СТРОКА(B7:B25)*(B7:B25<>"")))

=ДВССЫЛ("C"&МАКС(СТРОКА(C7:C25)*(C7:C25<>"")))

Формулы могут быть введены в любые столбцы.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (1 оценка)