Выделение трех наибольших значений

Выделим с помощью Условного форматирования три наибольших значения в списке.

Пусть в диапазоне А6:А24 имеется список значений.

В ячейку D5 введите формулу для определения третьего наибольшего =НАИБОЛЬШИЙ(A6:A24;3)

Выделите диапазон со списком, в правиле Условного форматирования введите формулу =$A6>=$D$5

Совет. Тот же самый результат можно получить с помощью предопределенного правила Условного форматирования Первые 10 элементов.

Задача решена, однако если в списке имеются повторы, то задача имеет продолжение...

Выделение не включая повторы

В нашем списке будет выделено не 3, а 4 значения, т.к. в списке имеются повторы (два числа 10, которые равны третьему наибольшему).

Чтобы учесть наличие повторов и выделять только 3 значения, необходимо настроить Условное форматирование другим способом (см. файл примера лист Повторы учитываются).

Сначала для каждого числа рассчитаем его ранг (о ранге см. статью Функция РАНГ() в MS EXCEL).  Ранг числа — это его величина относительно других значений в списке. Если отсортировать список, то ранг числа будет его позицией.

Ранг числа рассчитаем не по классическому правилу, когда повторы имеют одинаковый ранг, а с помощью формулы =СЧЁТЕСЛИ($A$6:$A$24;">"&A6)+СЧЁТЕСЛИ($A$6:A6;A6)

Повторы будут иметь разный ранг: то значение которое выше - будет иметь ранг больше.

Новое правило Условного форматирования будет иметь вид:

Теперь повторы выделены не будут.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (1 оценка)
Яндекс.Метрика