Восстанавливаем последовательности из списка без повторов в MS EXCEL

В статье Отбор уникальных значений (убираем повторы из списка) в MS EXCEL было показано как из списка с повторами отобрать только уникальные значения. В этой статье покажем как решить обратную задачу: имея список значений без повторов и количество повторов этих значений, создадим список повторяющихся значений.

Пусть в столбце А имеется список значений без повторов (буквы А, B, С ...), а в соседнем столбце В - указано количество повторов каждого из значений.

На основании этой информации в столбце D создадим список с повторами. Таким образом, создадим последовательность текстовых значений (подробнее о последовательностях см. статьи Текстовые последовательности в MS EXCEL и Числовые последовательности в MS EXCEL (порядковые номера 1,2,3... и др.)

СОВЕТ: Еще один случай создания последовательностей рассмотрен в статье Комбинации элементов из нескольких множеств: Комбинаторика в MS EXCEL.

Решение

Значения в список с повторами будем выводить с помощью функции СМЕЩ(). Формула =СМЕЩ($A$7;F7;) будет выводить 1 элемент из столбца А в зависимости от второго аргумента функции - смещения по строкам. Осталось найти смещение по строкам в зависимости от уже введенного количества повторов в столбец D.

Количество повторов каждого значения найдем с помощью формулы =СЧЁТЕСЛИ($D$7:D7;D7)

Наконец, смещение по строкам найдем с помощи формулы =ЕСЛИ(E7=ИНДЕКС($B$7:$B$9;ПОИСКПОЗ(D7;$A$7:$A$9;0));F7+1;F7)

Формула сравнивает количество уже введенных повторов с заданным количеством повторов. Решение можно найти в файле с примером.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (1 оценка)