Умножение матриц в MS EXCEL

В этой статье рассмотрены операции умножения матриц с помощью функции МУМНОЖ() или англ.MMULT и с помощью других формул, а также свойства ассоциативности и дистрибутивности операции умножения матриц. Примеры решены в MS EXCEL.

Операция умножения двух матриц А и В определена только для случаев, когда число столбцов матрицы А равно числу строк матрицы В. 

Произведение матрицы А порядка P x N и матрицы В порядка N x Q - это такая матрица С порядка P x Q, у которой каждый элемент равен сумме произведений элементов i-ой строки матрицы А на соответствующие элементы j-ого столбца матрицы В, то есть:

Для умножения матриц в MS EXCEL существует специальная функция МУМНОЖ(), которую нужно вводить как формулу массива.

Рассмотрим сначала умножение квадратных матриц 2 х 2.

Разместим матрицы в диапазонах А8:В9 и D8:E9  (см. файл примера).

Результат, также матрицу 2 х 2, будем вводить в диапазон H8:I9.

Для этого:

  • выделите указанный диапазон H8:I9
  • поставьте курсор в Строку формул (или нажмите клавишу F2)
  • введите формулу =МУМНОЖ(A8:B9;D8:E9)
  • нажмите CTRL+SHIFT+ENTER

Выделенный диапазон заполнится элементами матрицы. В принципе можно выделить заведомо больший диапазон, в этом случае лишние ячейки будут заполнены ошибкой #Н/Д.

Удалить отдельный элемент матрицы А*В не удастся - только все элементы сразу (выделите весь диапазон и нажмите клавишу DEL). 

Чтобы изменить значения аргументов функции (например, поменять матрицы местами), выделите любую ячейку матрицы, нажмите F2, исправьте формулу и нажмите CTRL+SHIFT+ENTER.

Альтернативной формулой для перемножения матриц является формула массива =СУММПРОИЗВ($A8:$B8;ТРАНСП(D$8:D$9)). Введите формулу в верхнюю левую ячейку диапазона и нажмите CTRL+SHIFT+ENTER. Затем скопируйте ее вниз и вправо на нужное количество ячеек.

Если попытаться перемножить матрицы неподходящей размерности (когда число столбцов матрицы А НЕ равно числу строк матрицы В), то функция МУМНОЖ() вернет ошибку #ЗНАЧ!

В файле примера также продемонстрированы свойства ассоциативности и дистрибутивности операции умножения матриц.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4.3 (4 оценок)
Яндекс.Метрика