Сводная таблица для отбора Уникальных значений из списка MS EXCEL

Для отбора уникальных значений можно использовать формулырасширенный фильтр  или можно воспользоваться меню Данные/ Работа с данными/ Удалить дубликаты. В этой статье используем Сводные таблицы.

Пусть в столбце имеется список с повторяющимися значениями, например список с названиями компаний (см. файл примера). Столбец А содержит номера позиций уникальных значений.

Для наглядности уникальные значения в исходном списке выделены цветом с помощью Условного форматирования.

Используем сводную таблицу для создания списка уникальных значений. Для этого выделите столбец В таблицы с заголовком (т.е. столбец Исходный список) и во вкладке Вставка, в группе Таблицы нажмите кнопку Сводная таблица. 

Примечание: Выделять столбец требуется для того, чтобы сводная таблица содержала только одно поле (столбец В). В противном случае сводная таблица будет содержать 2 поля. Это не повлияет на вычисления, но для наглядности пока не будем включать в сводную таблицу столбец А.

Поле Сводной таблицы Исходный список перетащите в область Названия строк.

Список уникальных значений сформирован. Обратите внимание, что значения в сводной таблице отсортированы по возрастанию.

Сортировка как в источнике данных

Чтобы сохранить сортировку как в исходной таблице нам потребуется создать дополнительный столбец в источнике данных сводной таблицы. Для этого в столбце А введите формулу 

=ЕСЛИ(СЧЁТЕСЛИ($B$7:B8;B8)=1;СЧЁТ($A$7:A7)+1;"")

Эта формула пронумерует все первые повторы значений, остальные строки будут содержать значение Пустой текст "".

Теперь создадим другую сводную таблицу. Для этого нужно выделить любую ячейку в диапазоне таблице (А7:В22). В этой таблице будет 2 поля.

Поле Исходный список, как и для предыдущей таблицы, поместите в область строк. Поле Позиция поместите в область значений. Нажмите на это поле в области значений и в меню выберите пункт Параметры полей значений... В появившемся диалоговом окне выберите Минимум.

В итоге получим сортировку как в исходной таблице.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (1 оценка)