Создание таблиц с неповторяющимися строками в MS EXCEL

Создадим таблицу, состоящую только из неповторяющихся строк.

В статье Создание списка неповторяющихся значений было показано, как запретить ввод повторов в одном столбце, что позволило создать перечень неповторяющихся фамилий сотрудников. Если необходимо, чтобы неповторяющимися были не отдельные фамилии, а полные имена (ФИО), то необходимо модифицировать упомянутый пример. Далее предполагается, что имя, фамилия и отчество вводятся в различные ячейки.

Создадим в столбцах А, B, C таблицу, состоящую только из неповторяющихся строк. В столбце А будем вводить Фамилию, в столбце ВИмя, а в СОтчество (см. файл примера).

Сведем задачу к случаю рассмотренному в статье Создание списка неповторяющихся значений. Создадим вспомогательный столбец D, в котором (в ячейке D11) поместим формулу для отображения полного ФИО: =A11&B11&C11. Скопируем формулу вниз до D24.

  • выделите диапазон А11:С24;
  • вызовите инструмент Проверка данных (Данные/ Работа с данными/ Проверка данных);
  • на вкладке Параметры выберите тип данных Другой;
  • в поле Формула введите: =СЧЁТЕСЛИ($D$11:$D$24;$D11)<2
  • Нажмите ОК.

В формуле использована смешанная адресация, поэтому при вводе формулы важно какая ячейка является активной (A11). Адрес активной в данный момент ячейки отображается в поле Имя, слева от Строки формул.

Недостаток. При создании списка этим методом можно оставлять пропуски, что нежелательно для дальнейшей работы со списками.

Чтобы запретить пропуски в диапазоне нужно изменить формулу:
=И(СЧЁТЕСЛИ($D$11:$D$24;$D11)<2;СЧЁТЕСЛИ($D$11:$D11;"")=0)

СОВЕТ:
Для визуального контроля уникальности вводимых значений можно использовать идеи из статьи Выделение повторяющихся значений.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4.5 (2 оценок)