Сортированный список в MS EXCEL (ЧИСЛОвые значения)

Сортировку списка можно осуществить через меню Данные/ группа Сортировка и фильтр/ Сортировка. В случае, если в исходный список постоянно вводятся новые значения, то для поддержания списка в сортированном состоянии, пользователь должен каждый раз вручную сортировать список через меню, что не всегда удобно. Гораздо удобнее иметь динамически сортирующийся список. Список состоит из числовых значений.

Сортированный список может быть полезен при создании Выпадающего (раскрывающегося) списка. Некоторые функции для нормальной работы также требуют сортированный список: ПРОСМОТР(), ВПР(), ПОИСКПОЗ().

Сортировка числового списка через меню

Сортировку списка можно осуществить через меню Данные/ группа Сортировка и фильтр/ Сортировка. Для этого выделите самое первое (верхнее) числовое значение в списке (предполагается, что все значения введены в одном столбце без пустых ячеек) и нажмите в меню соответствующую кнопку сортировки.

Если список содержит пустые ячейки, то сортировка будет произведена только до первой пустой ячейки. Но, если предварительно выделить весь диапазон значений (вместе с пустыми ячейками), то данные будут отсортированы полностью, причем пустые ячейки будут расположены внизу списка (это не зависит от направления сортировки).

Сортировка формулами (динамическая сортировка)

Если список содержит только числовые значения, то его сортировку можно сделать с помощью функций НАИМЕНЬШИЙ() и СТРОКА() (см. файл примера).

Для сортировки от минимального к максимальному используем формулу (введите ее в ячейку B4 и скопируйте вниз, например, Маркером заполнения):
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ($A$4:$A$21;СТРОКА()-СТРОКА($B$3));"").

Функция НАИМЕНЬШИЙ() сортирует исходный список и выводит, в соответствии со значением второго аргумента, элементы списка. Формула СТРОКА()-СТРОКА($B$3) задает порядковые числа (1, 2, 3, 4,..) для второго аргумента функции НАИМЕНЬШИЙ().

Если исходный диапазон охватывает пустые ячейки, то необходима функция подавления ошибки ЕСЛИОШИБКА(). После заполнения незаполненных ячеек, входящих в диапазон А4:А21, список в столбце В будет отсортирован автоматически.

Примечание. Функция ЕСЛИОШИБКА() появилась начиная с версии MS EXCEL 2007. О том как ее заменить для более ранних версий см. Функция ЕСЛИОШИБКА() в MS EXCEL.

Абсолютную ссылку на диапазон исходного списка $A$4:$A$21 можно заменить ссылкой на Динамический диапазон, границы которого будут изменяться от количества введенных значений (см. файл примера).

СОВЕТ: Решение задачи о сортировке списка с текстовыми значениями приведено в одноименной статье Сортировка списка с текстовыми значениями.

Для сортировки от максимального к минимальному используйте функцию НАИБОЛЬШИЙ().

Также для сортировки числовых списков можно использовать функции ПРОЦЕНТИЛЬ.ВКЛ() и ПЕРСЕНТИЛЬ() (см. файл примера).

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (4 оценок)

Комментарии

Tatiana

Не знаю куда делся предыдущий мой коммент но подскажите где найти стать. Сортировка списка с текстовыми значениями?поиск по сайту не помог.Нужно в уже созданную(по советам вашего сайта) таблицу добавлять наименование строек и чтоб целая строка перескакивала автоматически в алфавитном порядке в таблице.Спасибо.

Tatiana

А вообще ОГРОМНОЕ СПАСИБО ЗА САЙТ РЕБЯТА!!! НАЧИНАЕМ УЧИТЬСЯ ЕЗДИТЬ!!!СПАСИБО!!!Сколько было бестолково потраченно времени на рисование таблиц вручную и пр...Спасибо!

Wasp

Пожалуйста, сейчас "дотачиваем" структуру представления статей. Чтобы не было большой свалки :)

Creator

Статья о сортировке текстовых чисел добавлена по адресу http://excel2.ru/articles/sortirovka-spiska-s-tekstovymi-znacheniyami

Tatiana

Спасибо что откликнулись и сделали сорт список по текстовым значениям.Респект. С-П-А-С-И-Б-О

MCH

ЕСЛИОШИБКА() не работает в Excel старше 2007 версии, здесь подойдет формула:
=ЕСЛИ(СЧЁТ(A$4:A$21)<ЧСТРОК(B$4:B4);"";НАИМЕНЬШИЙ(A$4:A$21;ЧСТРОК(B$4:B4)))

Яндекс.Метрика