Сложение значений на основании их повторяемости (Часть3.Сложение Повторяющихся) в MS EXCEL

Диапазон суммирования содержит повторяющиеся значения. Произведем только тех чисел, которые имеют повторы.

В качестве диапазона суммирования возьмем диапазон (А2:А10), содержащий повторяющиеся значения: 986; 456; 67; 1;  34; 689; 456; 56; 67

Подсчитаем сумму только повторяющихся значений.

Используем формулу массива:
=СУММ(ЕСЛИ(СЧЁТЕСЛИ(A2:A10;A2:A10)>1;A2:A10;""))

Эту формулу необходимо ввести как формулу массива, т.е. после ввода формулы, нужно вместо ENTER нажать CTRL+SHIFT+ENTER.

СОВЕТ:
О сложении уникальных значений можно прочитать здесь. О сложении неповторяющихся значений можно прочитать здесь.

О том как выделить повторяющиеся значения написано в одноименной статье Выделение повторяющихся значений.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (2 оценок)