Сложение с одним критерием в MS EXCEL (Часть3.Критерий - ДАТА)

Для суммирования значений по одному диапазону на основе данных другого диапазона используется функция СУММЕСЛИ(). Рассмотрим случай, когда критерий применяется к диапазону с датами.

Пусть дана таблица с датой поставки партий и их количеством (см. файл примера).

 

Задача

Найдем суммарное количество всех поставок, для которых дата поставки позднее 10.08.11.

Решение

Поскольку любой дате в EXCEL соответствует число (см. статью Как EXCEL хранит дату и время), то подход к решению задачи практически аналогичен случаю, когда критерий применяется к диапазону суммирования (см. статью СУММЕСЛИ - Сложение по условию (один Числовой критерий)):
=СУММЕСЛИ(A3:A13;">10.08.11";B3:B13)

Результат: суммируются числа из столбца B, которым соответствует дата позднее 10.08.11.

Даты, удовлетворяющие критерию, выделены Условным форматированием.

СОВЕТ:
В статье Сложение по условию (один Текстовый критерий) рассмотрен случай, когда критерий применяется к соседнему диапазону, содержащему текстовые значения, а суммирование производится только соответствующих ячеек из числового диапазона.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (2 оценок)
Яндекс.Метрика