Скрытие значений в MS EXCEL равных 0

Иногда требуется скрыть значения равные 0. Сделаем это несколькими способами.

Скрыть значения равные 0 во всех ячейках на листе можно через Параметры MS EXCEL (далее нажмите Дополнительно/ Раздел Показать параметры для следующего листа/, затем снять галочку Показывать нули в ячейках, которые содержат нулевые значения).

Скрыть значения равные 0 в отдельных ячейках можно используя пользовательский формат, Условное форматирование или значение Пустой текст ("").

Пользовательский формат

Пользовательский формат вводим через диалоговое окно Формат ячеек.

  • для вызова окна Формат ячеек нажмите CTRL+1;
  • выберите (все форматы).
  • в поле Тип введите формат # ##0,00;-# ##0,00;

Применение вышеуказанного формата не влияет на вычисления. В Строке формул, по-прежнему, будет отображаться 0, хотя в ячейке ничего не будет отображаться.

Условное форматирование

Используя Условное форматирование, также можно добиться практически такого же результата.

  • выделите интересующий диапазон;
  • в меню выберите Главная/ Стили/ Условное форматирование/ Правила выделения ячеек/ Равно);
  • в левом поле введите 0;
  • в правом поле выберите пользовательский формат (белый цвет шрифта);

Теперь нулевые значения отображаются белым шрифтом и не видны на стандартном белом фоне.

Если фон поменять, то нули станут снова видны, в отличие от варианта с пользовательским форматом, который не зависит от фона ячейки. Даже если просто выделить диапазон, то нулевые ячейки будут слегка видны.

Значение Пустой текст ("")

Замечательным свойством значения Пустой текст является, то что оно не отображается в ячейке (например, введите формулу =""). Записав, например, в ячейке B1 формулу =ЕСЛИ(A1;A1;"") получим пустую ячейку В1 в случае, если в А1 находится значение =0. Столбец А можно скрыть.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (2 оценок)

Комментарии

Юрий (не проверено)

Танцы с бубном :-))
В Параметрах/дополнительно снимите галочку "Показывать нули в ячейках ..."

Creator

Спасибо. Этот подход позволяет не показывать 0 в ячейках на всем листе. Если требуется в одной таблице на листе отключить показ 0, а в другой, на том же листе, оставить все без изменений, то нужно использовать другие подходы, описанные в статье.