Пользовательский формат ДАТЫ и ВРЕМЕНИ в MS EXCEL

Пользовательский формат – это формат отображения значения задаваемый пользователем. Например, дату 13/01/2010 можно отобразить как: 13.01.2010 или 2010_01_13 или 13-Январь-10.

Пользовательский формат можно применить через Формат ячеек или определить в функции ТЕКСТ(). В этой статье приведены некоторые примеры пользовательского формата даты и времени (см. файл примера).

Форматы Даты (на примере значения 01.02.2010 12:05)

Формат

Название

Результат для 01.02.2010 12:05

М

Месяц (заглавная буква М)

2

ММ

месяц

02

МММ

 

фев

ММММ

 

Февраль

д

день

1

дд

 

01

ддд

сокращенный день недели

Пн

дддд

день недели

понедельник

д.М

 

1.2

гг (или г)

год

10

гггг (или ггг)

 

2010

д.М.гг

 

1.2.10

дд.ММ.гггг чч:мм

полный формат даты

01.02.2010 12:05

ДД МММ ГГГГ

 

01 фев 2010

дд-ММ-гггг

 

01-02-2010

ГГГГ\_ММ\_ДД

Пользовательский формат

2010_02_01

ДДД, ДД|ММ|ГГ Пользовательский формат Пн, 01|02|10

ДД-ММММ-ГГ

Пользовательский формат

13-Январь-10

Форматы времени (на примере значения 12:05 дня)

Формат

Название

Результат для 12:05дня

м

минуты

5

мм

минуты

05

ч:мм AM/PM

 

12:05 PM

ч:мм:сс

 

12:05:00

[ч]

подсчет кол-ва часов

12

[м]

подсчет кол-ва минут

725 (12*60+5)

Пользовательский формат не влияет на вычисления, меняется лишь отображения числа в ячейке. Пользовательский формат можно ввести через диалоговое окно Формат ячеек, вкладка Число, (все форматы), нажав CTRL+1. Сам формат вводите в поле Тип, предварительно все из него удалив. Более подробно о применении пользовательского формата читайте в статье Числовой пользовательский формат.

В случае использования функции ТЕКСТ() используйте следующий синтаксис: =ТЕКСТ(СЕГОДНЯ();"здесь укажите требуемый формат"). Например, =ТЕКСТ(СЕГОДНЯ();"дд.ММ.гггг")

Естественно, вместо функции СЕГОДНЯ() можно использовать либо дату, либо формулу, вычисление которой дает числовое значение, представляющее собой дату, либо ссылку на ячейку, содержащую дату. О том, как EXCEL хранит дату и время можно прочитать в одноименной статье Как Excel хранит дату и время.

Еще один пример: число 1300 можно отобразить как Время (13:00) с помощью формата 00\:00 (обратный слеш нужен для корректного интерпретирования двоеточия). Результат 13:00. Но EXCEL будет продолжать производить вычисления с 1300 как с обычным числом (меняется только отображения числа 1300). При прибавлении 65 вместо 14:05 получим 13:65. Аналогичная функция с пользовательским форматом: =ТЕКСТ(1300;" 00\:00")

Этот формат полезен для ускорения ввода, см. статью Ускорение ввода значений в формате времени.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (2 оценок)

Комментарии

букин (не проверено)

Добрый день, подскажите пожалуйста как можно заполнить автоматически дату и время в смежных ячейках? т.е. А1-это дата В1 текущее время, С1 - информация о работе системы. т.е. при вводе данных в яч.С1 текста "система ОК или Система ВР" мне бы хотелось чтобы яч. АВ заполнялись автоматически в реальном времени. сейчас я пользуюсь CTRL
+ точка и запятая, для ввода даты/время.хотелось бы автоматизировать .Спасибо.

TMP

Сделать, то что Вы просите без использования VBA невозможно. При написании программы VBA используйте следующие функции VBA: Date, Time и событие листа Worksheet_Change. На настоящий момент наш сайт посвящен использованию только стандартного функционала Excel без VBA.

букин (не проверено)

Спасибо за ответ, до VBA я еще не дорос.Классный сайт!

Екатерина (не проверено)

Огроомное спасибо! А то я так измучилась, потому что при использовании слиянии (Mail Merge)формат выгружался совсем неправильно! А теперь я знаю, как задать нужный мне формат!

Виктория (не проверено)

Добрый день. Можно ли задать в ячейке например 01.09.2014-07.09.2014 а под ней отображение следующей недели 08.09.2014-14.09.2014 и так далее? заранее спасибо

Creator

Если Вы введете в ячейке 01.09.2014-07.09.2014, то это будет текст, а не дата. Поэтому предлагаю следующий подход: в ячейке А1 введите дату начала недели 01.09.2014, в ячейке B1 введите формулу =ТЕКСТ(A1;"дд.ММ.гггг")&"-"&ТЕКСТ(A1+6;"дд.ММ.гггг") Результат формулы - 01.09.2014-07.09.2014

В ячейке А2 введите =A1+7 (результат 08.09.2014), формулу из В1 скопируйте вниз в В2. Результат формулы - 08.09.2014-14.09.2014

Формулы из строки 2 скопируйте вниз. В итоге в столбце В появятся текстовые строки: 01.09.2014-07.09.2014, 08.09.2014-14.09.2014, 15.09.2014-21.09.2014 и т.д.

Виктория (не проверено)

Спасибо