Поиск в MS EXCEL текстового значения первого или последнего по алфавиту

Найдем текстовое значение, которое при сортировке диапазона по возрастанию будет выведено первым, т.е. первое по алфавиту. Также найдем последнее значение по алфавиту.

Пусть имеется диапазон текстовых значений (A4:A12).

Найдем значение, которое при сортировке диапазона по возрастанию будет выведено первым, т.е. первое по алфавиту (см. Файл примера).

Приведем решение.

Свойство

Решение

Если несколько значений удовл. критерию

Первое по алфавиту

=ИНДЕКС($A$4:$A$12; ПОИСКПОЗ(НАИМЕНЬШИЙ( СЧЁТЕСЛИ($A$4:$A$12;"<"&$A$4:$A$12);1); СЧЁТЕСЛИ($A$4:$A$12; "<"&$A$4:$A$12); 0))

берется первое сверху

Последнее по алфавиту

=ИНДЕКС($A$4:$A$12; ПОИСКПОЗ(НАИБОЛЬШИЙ( СЧЁТЕСЛИ($A$4:$A$12;"<"&$A$4:$A$12);1); СЧЁТЕСЛИ($A$4:$A$12; "<"&$A$4:$A$12); 0))

берется первое сверху

Решения реализованы с использованием формул массива.

Для пошагового просмотра хода вычислений используйте клавишу F9.

Логическое продолжение этой статьи – сортировка исходного списка, об этом читайте в статье Сортированный список.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4.5 (2 оценок)

Комментарии

MCH

В данном случае, НАИБОЛЬШИЙ(...;1)/НАИМЕНЬШИЙ(...;1) можно заменить на МАКС()/МИН()