Поиск ЧИСЛОвых значений и вывод соответствующих значений в отдельный список в MS EXCEL

Найдем числовые значения, равные заданному пользователем критерию. Поиск будем осуществлять в диапазоне с повторяющимися значениями. При наличии повторов, можно ожидать, что критерию будет соответствовать несколько значений. Для их вывода в отдельный диапазон удобно использовать формулы массива.

Пусть имеется перечень учеников класса. Каждому ученику в случайном порядке достался вариант контрольной работы (от 1 до 5) (см. файл примера), диапазон A7:B25.

Задача

Необходимо в отдельном столбце вывести фамилии тех учеников, кому достался, например, вариант 5.

Решение

Для удобства написания формул создадим именованные диапазоны Вариант (A7:A25) и Ученик (B7:B25).

По аналогии с решением из статьи Поиск текстовых значений в списках. Часть1. Обычный поиск напишем формулу массива для вывода интересующих нас значений:

=ЕСЛИОШИБКА(ИНДЕКС(Ученик;
НАИМЕНЬШИЙ(ЕСЛИ(D7=Вариант;СТРОКА(Вариант)-СТРОКА($A$6);9999);
СТРОКА(ДВССЫЛ("A1:A"&ЧСТРОК(Вариант)))));"")

С помощью Выпадающего списка в ячейке D7 пользователь может выбрать вариант от 1 до 5. Соответствующие фамилии учеников будут выведены в столбце F.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (2 оценок)

Комментарии

sandra_m

помогите пожалуйста!!!! надо что-бы значение в ячейке выбиралось из другого листа при условии что значение в предыдущем столбце равно значению в предыдущем столбце на другом листе.

sandra_m

не нашла где прикрепить файл с вариантом, опишу здесь:
Лист1 Лист 2
1 Света 3 Дима
2 Рома 1 Света
3 Дима 2 Рома
В листе 2 в ячейке с именем, надо прописать формулу, где будет вытаскиваться значение с Листа 1. Т.е. при условии что значение в 1 столбце равно 1, то значение равно Света из листа 1, и т.д. по номерам

Creator

Добрый день, посмотрите статьи http://excel2.ru/articles/spravochnik-v-ms-excel или http://excel2.ru/articles/funkciya-vpr-v-ms-excel-vpr

Если не поможет, то пишите на creator@excel2.ru