Поиск ближайшего события в MS EXCEL

Пусть имеется список неких событий, например, праздников. Найдем ближайшее событие, которое еще не произошло.

В диапазоне A7:B15 имеется список праздников (или расписание каких-либо событий).

Задача

Определим ближайшее событие, которое еще не произошло. Текущую дату разместим в ячейке D7.

Решение

Решением является формула массива из статьи Поиск ДАТЫ ближайшей к заданной:

=ЕСЛИОШИБКА(
ИНДЕКС(B7:B17;ПОИСКПОЗ(МИН(ЕСЛИ(A7:A17>=D7;A7:A17;""));A7:A17;0);1)
;"Событий нет")

Для пошагового просмотра хода вычислений формулы можно воспользоваться клавишей F9.

Если дата-критерий (ячейка D7) позднее, чем самая последняя дата в списке, то формула выведет строку "Событий нет".

Для работы формулы сортировка списка по дате не требуется, но она потребуется для правила Условного форматирования, которое будет выделять результат формулы массива.

Последнее прошедшее событие

Для того, чтобы найти последнее прошедшее событие можно воспользоваться функцией ВПР():

=ВПР(D7;A7:B17;2;ИСТИНА)

Для функции ВПР() требуется сортировка списка дат по возрастанию.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4.3 (4 оценок)
Яндекс.Метрика