Подсчет Уникальных значений с условиями в MS EXCEL

Подсчитаем Уникальные значения с одним и двумя условиями.

Про подсчет уникальных текстовых и числовых значений (без условий) можно прочитать в статье Подсчет Уникальных ТЕКСТовых значений в MS EXCEL и Подсчет Уникальных ЧИСЛОвых значений в MS EXCEL. В этой статье рассмотрим более сложные варианты с условиями.

Задача1

Пусть имеется таблица с перечнем продаж по продавцам.

Требуется подсчитать сколько различных товаров продал конкретный продавец. Например, Вася продал 1 товар1, 2 Товара2 и 1 Товар4 (выделено зеленым). Всего 3 разных товара.

Это можно подсчитать формулой =СУММПРОИЗВ((A13:A21=A7)/СЧЁТЕСЛИМН(B13:B21;B13:B21;A13:A21;A13:A21)), которая будет работать только с версии MS EXCEL 2007 из-за функции СЧЁТЕСЛИМН().

Изменив в ячейке А7 имя продавца (в файле примера для удобства сделан выпадающий список), формула пересчитает количество уникальных.

Задача2

Аналогичным образом можно решить задачу с двумя условиями.

=СУММПРОИЗВ(((A14:A23=A8)*(B14:B23=B8))/СЧЁТЕСЛИМН(A14:A23;A14:A23;B14:B23;B14:B23;C14:C23;C14:C23))

В этом случае будут подсчитаны уникальные товары только в строках, для которых Продавец и Месяц совпадают с критериями, установленными в желтых ячейках.

В файле примера на листе Два критерия приведено решение этой задачи с помощью Сводной таблицы. В этом случае выводится не количество уникальных, а список уникальных товаров.

Задача3

Теперь рассмотрим другую таблицу (столбцы А:С на рисунке ниже).

Необходимо вывести количество заключенных договоров в каждом месяце.

Т.к. в таблице ведется учет счетов сразу для всех договоров и по каждому договору может быть выставлено несколько счетов, то номера договоров могут повторяться.

Создадим дополнительный столбец для определения месяца заключения договора (см. статью Название месяца прописью в MS EXCEL). Выведем из этого столбца только уникальные месяцы (см. статью Отбор уникальных значений (убираем повторы из списка) в MS EXCEL) и поместим их в столбец F.

И, наконец, помощью формулы =СУММПРОИЗВ(($D$9:$D$26=F9)/СЧЁТЕСЛИ($A$9:$A$26;$A$9:$A$26)) подсчитаем количество уникальных договоров в соответствующем месяце.

Решение также возможно с помощью Сводной таблицы.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (2 оценок)