Подсчет ТЕКСТовых значений (в диапазонах с ТЕКСТом и ЧИСЛАми) в MS EXCEL

Подсчитаем количество ячеек содержащих текст. Предполагаем, что диапазон содержит и текст и числа и пустые ячейки.

Пусть диапазон суммирования находится в ячейках A1:A10. Предположим, что диапазон содержит и текст и числа и пустые ячейки. Функция СЧЁТЗ() подсчитает и текст и числа, поэтому она не годится.

Подсчитаем количество ячеек содержащих текстовые значения с помощью других формул (см. файл примера):

=СУММПРОИЗВ(--(A1:A10>""))

или другой вариант:
=СУММПРОИЗВ(--ЕТЕКСТ(A1:A10))
или
=СУММПРОИЗВ(ЕТЕКСТ(A1:A10)+0)

еще варианты:
=СЧЁТЗ(A1:A10)-СЧЁТ(A1:A10)
=СЧЁТЕСЛИ(A1:A10;"*?")

Если число находится в текстовом формате, то оно также будет подсчитано. Если нужно подсчитать только те значения, которые не могут быть преобразованы в число, то нужно использовать формулу массива:
=СУММ(ЕСЛИ(ЕОШ(A1:A10+0);1;0))

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (2 оценок)