Подсчет символов в диапазоне в MS EXCEL

Найдем количество вхождений определенного символа в диапазоне ячеек.

Определим, сколько букв Z содержится в диапазоне А7:A11.

Формула для подсчета (с учетом РЕгиСТра), см. файл примера:
=СУММПРОИЗВ(ДЛСТР(A7:A11)-ДЛСТР(ПОДСТАВИТЬ(A7:A11;B4;"")))

Формула для подсчета (без учета РЕгиСТра):
=СУММПРОИЗВ(ДЛСТР(A7:A11)-ДЛСТР(ПОДСТАВИТЬ(СТРОЧН(A7:A11);"z";"")))

Формула для одновременного подсчета символов Z и цифры 1 в диапазоне А7:A11 (без учета РЕгиСТра):
=СУММПРОИЗВ(ДЛСТР(A7:A11)-ДЛСТР(ПОДСТАВИТЬ(СТРОЧН(A7:A11); {"z";"1"};"")))

Аналогичная формула =СУММПРОИЗВ(ДЛСТР(A7:A11)-ДЛСТР(ПОДСТАВИТЬ(СТРОЧН(A7:A11); {"1";"2"};""))) может подсчитать количество цифр (1 и 2) в диапазонах с числами. 

Пусть в диапазоне А7:A11 содержатся числа 1; 22; 123; 8; 5. Формула, приведенная выше, вернет 5, т.к. в диапазоне содержится две цифры 1 (в числах 1 и 123) и три цифры 2 (в числах 22 и 123).

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (3 оценок)